summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2015-07-08 15:35:55 +0300
committervlad2015-07-08 15:35:55 +0300
commitf2b9a94de57478ca38cfec6b51121323faa5e0cb (patch)
tree006334597ad3421d1cc338a77e4a2120bafd943c
downloadaur-f2b9a94de57478ca38cfec6b51121323faa5e0cb.tar.gz
Initial import
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD55
-rw-r--r--utox-git.install15
3 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..989c5a135c50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = utox-git
+ pkgdesc = Lightweight Tox client
+ pkgver = r1519.c46ae4c
+ pkgrel = 1
+ url = https://github.com/notsecure/uTox
+ install = utox-git.install
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ makedepends = git
+ depends = desktop-file-utils
+ depends = fontconfig
+ depends = libfilteraudio-git
+ depends = hicolor-icon-theme
+ depends = libdbus
+ depends = libxext
+ depends = libxrender
+ depends = openal
+ depends = tox-git
+ depends = v4l-utils
+ optdepends = gtk2: GTK file picker
+ provides = utox
+ conflicts = utox
+ source = utox-git::git+https://github.com/notsecure/uTox
+ md5sums = SKIP
+
+pkgname = utox-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0954339f911c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: HÃ¥vard Pettersson <mail@haavard.me>
+# Contributor: Madotsuki <madotsuki at cock dot li>
+
+_pkgname=utox
+pkgname=utox-git
+pkgver=r1519.c46ae4c
+pkgrel=1
+
+pkgdesc='Lightweight Tox client'
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+url='https://github.com/notsecure/uTox'
+license=('GPL3')
+
+depends=(
+ 'desktop-file-utils'
+ 'fontconfig'
+ 'libfilteraudio-git'
+ 'hicolor-icon-theme'
+ 'libdbus'
+ 'libxext'
+ 'libxrender'
+ 'openal'
+ 'tox-git'
+ 'v4l-utils'
+)
+makedepends=('git')
+optdepends=('gtk2: GTK file picker')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+source=("${pkgname}::git+https://github.com/notsecure/uTox")
+md5sums=('SKIP')
+
+install="${pkgname}.install"
+
+pkgver()
+{
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build()
+{
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+package()
+{
+ cd "${srcdir}/${pkgname}"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+}
+
+
diff --git a/utox-git.install b/utox-git.install
new file mode 100644
index 000000000000..4361e58e9393
--- /dev/null
+++ b/utox-git.install
@@ -0,0 +1,15 @@
+post_install()
+{
+ xdg-icon-resource forceupdate --theme hicolor &>/dev/null
+ update-desktop-database -q
+}
+
+post_upgrade()
+{
+ post_install $1
+}
+
+post_remove()
+{
+ post_install $1
+}