summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBoostCookie2020-04-13 14:16:46 +0200
committerBoostCookie2020-04-13 14:16:46 +0200
commitd8e979193d72e5fa88ed8141ca5967a229966782 (patch)
tree3bbf606016a7b7104729a4c75741cdc5e779e486
downloadaur-d8e979193d72e5fa88ed8141ca5967a229966782.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d8d7a2c4587
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = utqemu-git
+ pkgdesc = Ubuntu qemu is an easy to use ubuntu touch emulator/virtual machine
+ pkgver = r26.cd7bb30
+ pkgrel = 1
+ url = https://github.com/ubports/utqemu
+ arch = any
+ license = LGPL3
+ makedepends = git
+ depends = qemu
+ source = utqemu-git::git+https://github.com/ubports/utqemu.git
+ md5sums = SKIP
+
+pkgname = utqemu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33c903cb45c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Stefan Gehr <stefangehr@protonmail.com>
+pkgname=utqemu-git
+pkgver=r26.cd7bb30
+pkgrel=1
+pkgdesc="Ubuntu qemu is an easy to use ubuntu touch emulator/virtual machine"
+arch=('any')
+url="https://github.com/ubports/utqemu"
+license=('LGPL3')
+depends=('qemu')
+makedepends=('git')
+source=("${pkgname}::git+https://github.com/ubports/utqemu.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$pkgname/src"
+ install -Dm755 utq.sh "$pkgdir"/usr/bin/utq
+}