aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoel2022-08-25 13:47:47 -0700
committerNoel2022-08-25 13:47:47 -0700
commitd763a8c1a2912348521f65562911445d7ae07e08 (patch)
treec879fb8df3e40e1b4c97d37aa4cd6b67bbffcc6e
downloadaur-d763a8c1a2912348521f65562911445d7ae07e08.tar.gz
chore: publish aur package `utt-bin`
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD14
-rw-r--r--README.md9
5 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b627078f01d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = utt-bin
+ pkgdesc = utt is the universal text transformer
+ pkgver = 0.0.6
+ pkgrel = 1
+ url = https:/github.com/queer/utt
+ arch = x86_64
+ license = MIT
+ source = utt::https://github.com/queer/utt/releases/download/0.0.6/utt
+ sha256sums = 69cf0802c01d808d157fc7c9ae66dfff7ad21522a19742a39506eb8968078ed1
+
+pkgname = utt-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bbb4be2c8dc7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+utt-*
+utt
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..30cd332ea421
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2022 Noel <cutie@floofy.dev>
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18d6acaefaaa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,14 @@
+# Maintainer: Noel <cutie@floofy.dev>
+pkgname=utt-bin
+pkgver=0.0.6
+pkgrel=1
+pkgdesc="utt is the universal text transformer"
+license=('MIT')
+arch=('x86_64')
+source=('utt::https://github.com/queer/utt/releases/download/0.0.6/utt')
+sha256sums=('69cf0802c01d808d157fc7c9ae66dfff7ad21522a19742a39506eb8968078ed1')
+url='https:/github.com/queer/utt'
+
+package() {
+ install -Dm0755 "${srcdir}"/utt "${pkgdir}"/usr/local/bin/utt
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..e934c56f1f74
--- /dev/null
+++ b/README.md
@@ -0,0 +1,9 @@
+# 🧩 utt-aur
+> *Unofficial AUR package for [queer/utt](https://github.com/queer/utt), a universal text transformer.*
+
+Read the original repository's [README](https://github.com/queer/utt) on what **utt** is.
+
+## Installation
+```sh
+yay -S utt-bin # Downloads a binary from the GitHub Releases page
+```