summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaizhao Zhang2020-05-11 13:17:22 +0800
committerKaizhao Zhang2020-05-11 13:17:22 +0800
commit8df848571cb68bd116c5c38568b8451bae64baba (patch)
tree4b0f49683036ac862f17825922c82696a395b18a
parent670c5e32521b6af9d23891215d068e2bae986738 (diff)
downloadaur-uvicorn.tar.gz
Updated to version 0.11.5
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD15
-rw-r--r--asgi_example.py14
-rw-r--r--asgi_example.sh1
5 files changed, 45 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25d6b74f81f1..d94cc6a63bd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,26 @@
pkgbase = uvicorn
pkgdesc = The lightning-fast ASGI server.
- pkgver = 0.11.3
- pkgrel = 2
+ pkgver = 0.11.5
+ pkgrel = 1
url = https://www.uvicorn.org/
arch = any
license = BSD
makedepends = python-setuptools
depends = python>=3.6
depends = python-click>=7.0
- depends = python-h11>=0.8.0
+ depends = python-click<8.0
+ depends = python-h11>=0.8
+ depends = python-h11<0.10
depends = python-httptools>=0.1.0
+ depends = python-httptools<0.2.0
depends = python-uvloop>=0.14.0
depends = python-websockets>=8.0
- optdepends = python-watchdog>=0.6: for watchdogreload support
+ depends = python-websockets<9.0
+ optdepends = python-watchdog>=0.6: watchdogreload support
+ optdepends = python-watchdog<0.7: watchdogreload support
options = !emptydirs
- source = https://github.com/encode/uvicorn/archive/0.11.3.tar.gz
- sha256sums = b19934169d8e032c06f372883d941c324f10187b147c6b33a12f464a3f63eeae
+ source = https://github.com/encode/uvicorn/archive/0.11.5.tar.gz
+ sha256sums = be40828a1cdabbc9fccf90b2d846f866f2c5e846e3ef7f75101cb3c76e9fc2df
pkgname = uvicorn
diff --git a/.gitignore b/.gitignore
index 924dfb95c209..0fb1fc32c153 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,9 @@
-pkg/
-src/
-*.tar.*
+*
+!.gitignore
+!PKGBUILD
+!*.install
+!*.sysusers
+!.SRCINFO
+
+!asgi_example.py
+!asgi_example.sh
diff --git a/PKGBUILD b/PKGBUILD
index 0e4eb41047c6..8032d266c421 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
pkgname=uvicorn
-pkgver=0.11.3
-pkgrel=2
+pkgver=0.11.5
+pkgrel=1
pkgdesc="The lightning-fast ASGI server."
arch=('any')
url="https://www.uvicorn.org/"
@@ -10,21 +10,26 @@ license=('BSD')
depends=(
'python>=3.6'
'python-click>=7.0'
- 'python-h11>=0.8.0'
+ 'python-click<8.0'
+ 'python-h11>=0.8'
+ 'python-h11<0.10'
'python-httptools>=0.1.0'
+ 'python-httptools<0.2.0'
'python-uvloop>=0.14.0'
'python-websockets>=8.0'
+ 'python-websockets<9.0'
)
makedepends=('python-setuptools')
optdepends=(
- 'python-watchdog>=0.6: for watchdogreload support'
+ 'python-watchdog>=0.6: watchdogreload support'
+ 'python-watchdog<0.7: watchdogreload support'
)
options=(!emptydirs)
source=(
"https://github.com/encode/uvicorn/archive/${pkgver}.tar.gz"
)
sha256sums=(
- 'b19934169d8e032c06f372883d941c324f10187b147c6b33a12f464a3f63eeae'
+ 'be40828a1cdabbc9fccf90b2d846f866f2c5e846e3ef7f75101cb3c76e9fc2df'
)
build() {
diff --git a/asgi_example.py b/asgi_example.py
new file mode 100644
index 000000000000..7604b9ad737a
--- /dev/null
+++ b/asgi_example.py
@@ -0,0 +1,14 @@
+async def app(scope, receive, send):
+ assert scope['type'] == 'http'
+
+ await send({
+ 'type': 'http.response.start',
+ 'status': 200,
+ 'headers': [
+ [b'content-type', b'text/plain'],
+ ],
+ })
+ await send({
+ 'type': 'http.response.body',
+ 'body': b'Hello, world!',
+ })
diff --git a/asgi_example.sh b/asgi_example.sh
new file mode 100644
index 000000000000..04d4bf82d5f9
--- /dev/null
+++ b/asgi_example.sh
@@ -0,0 +1 @@
+uvicorn asgi_example:app