summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2024-03-10 01:45:18 +0200
committerAdrian Perez de Castro2024-03-10 01:45:18 +0200
commitf01a2ba3ed16b615c72c7645029af25382d19623 (patch)
tree55e4b0385231f72f6e5b24908fe3392598c6f0d9
parentb8fef68b443c6d91dc0865b1d5ad36e67a2987fc (diff)
downloadaur-f01a2ba3ed16b615c72c7645029af25382d19623.tar.gz
Also build and install OTB fonts
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c66b216eea77..bc61c5f428c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = uw-ttyp0-font
pkgdesc = Bitmap monospaced font with unicode support and Powerline symbols
pkgver = 1.3
- pkgrel = 6
+ pkgrel = 7
url = http://people.mpi-inf.mpg.de/~uwe/misc/uw-ttyp0
arch = any
license = custom
makedepends = xorg-bdftopcf
+ makedepends = xorg-mkfontscale
makedepends = perl
+ makedepends = fonttosfnt
+ conflicts = uw-ttyp0-otb
+ conflicts = otb-uw_ttyp0
source = http://people.mpi-inf.mpg.de/~uwe/misc/uw-ttyp0/uw-ttyp0-1.3.tar.gz
sha512sums = 193966b826cafa313384f20e225d4a0b0057364ed23c2beaf27a59095fdb9079281fdc1d292592038512a56ec0387e531a28449344e2960f0ecd3e64c7a6f6e7
pkgname = uw-ttyp0-font
-
diff --git a/PKGBUILD b/PKGBUILD
index a89ae88d4af0..7b5297200047 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,13 @@ _encodings='uni i15'
pkgname=uw-ttyp0-font
pkgdesc='Bitmap monospaced font with unicode support and Powerline symbols'
pkgver=1.3
-pkgrel=6
+pkgrel=7
arch=('any')
url='http://people.mpi-inf.mpg.de/~uwe/misc/uw-ttyp0'
source=("${url}/uw-ttyp0-${pkgver}.tar.gz")
license=('custom')
-makedepends=('xorg-bdftopcf' 'perl')
+conflicts=('uw-ttyp0-otb' 'otb-uw_ttyp0')
+makedepends=('xorg-bdftopcf' 'xorg-mkfontscale' 'perl' 'fonttosfnt')
sha512sums=('193966b826cafa313384f20e225d4a0b0057364ed23c2beaf27a59095fdb9079281fdc1d292592038512a56ec0387e531a28449344e2960f0ecd3e64c7a6f6e7')
prepare () {
@@ -45,6 +46,11 @@ build () {
cd "uw-ttyp0-${pkgver}"
./configure --prefix=/usr --pcfdir=/usr/share/fonts/misc
make
+ mkdir -p otb
+ for i in genbdf/*.bdf ; do
+ o=${i#*/}
+ fonttosfnt -b -c -g 2 -m 2 -o "otb/${o%.bdf}.otb" "${i}"
+ done
}
package () {
@@ -56,4 +62,5 @@ package () {
"${pkgdir}/usr/share/fonts/misc/fonts.dir"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m644 otb/*.otb "${pkgdir}/usr/share/fonts/misc"
}