summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 21:59:59 -0600
committerBrian Bidulock2015-06-10 21:59:59 -0600
commit525e6111a098431ba13a91965eba11784f56eb1c (patch)
treeb06a176e8998292792e40078c03ecbd222a4a9bc
downloadaur-525e6111a098431ba13a91965eba11784f56eb1c.tar.gz
initial version
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD56
-rw-r--r--arrayextern.patch51
-rw-r--r--uwm.desktop12
4 files changed, 147 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd729e6929e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = uwm-git
+ pkgdesc = Micro (u) Window Manager
+ pkgver = 0.30.11
+ pkgrel = 1
+ url = http://uwm.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = AGPL3
+ makedepends = git
+ depends = xcb-util-renderutil
+ depends = xcb-util-image
+ depends = xcb-util-keysyms
+ depends = bash
+ depends = libpng
+ depends = libjpeg
+ depends = xcb-util-wm
+ provides = uwm
+ conflicts = uwm
+ backup = usr/share/X11/uwm/system.uwmrc
+ source = uwm-git::git://git.code.sf.net/p/uwm/code
+ source = arrayextern.patch
+ source = uwm.desktop
+ md5sums = SKIP
+ md5sums = e808fdf6d91ad062d0234ee72f30e4e1
+ md5sums = a16c73faeab8c1fc3c74f3320776789a
+
+pkgname = uwm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfdd3b7fc7d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+
+pkgname=uwm-git
+pkgver=0.30.11
+pkgrel=1
+pkgdesc="Micro (u) Window Manager"
+arch=('i686' 'x86_64')
+url="http://uwm.sourceforge.net/"
+license=('AGPL3')
+provides=('uwm')
+conflicts=('uwm')
+backup=(usr/share/X11/uwm/system.uwmrc)
+depends=('xcb-util-renderutil' 'xcb-util-image' 'xcb-util-keysyms' 'bash' 'libpng' 'libjpeg' 'xcb-util-wm')
+makedepends=('git')
+source=("$pkgname::git://git.code.sf.net/p/uwm/code"
+ "arrayextern.patch"
+ "uwm.desktop")
+md5sums=('SKIP'
+ 'e808fdf6d91ad062d0234ee72f30e4e1'
+ 'a16c73faeab8c1fc3c74f3320776789a')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags --always | sed 's,^[^0-9]*,,;s,-,.,g;s,\.g[a-f0-9]*$,,'
+}
+
+prepare() {
+ cd $pkgname
+ git submodule update --init --recursive
+ sed 's,/usr/local/etc/system.uwmrc,/usr/share/X11/uwm/system.uwmrc,' -i uwm.h
+ sed 's,/usr/local/etc/system.uwmrc,/usr/share/X11/uwm/system.uwmrc,' -i uwmrc.5
+ sed 's,/etc/system.uwmrc /usr/local/etc/system.uwmrc,/usr/share/X11/uwm/system.uwmrc,' -i uwm.1
+ cd core-array
+ patch -Np1 <../../arrayextern.patch
+}
+
+build() {
+ cd $pkgname
+ make
+ make contrib/uwm-helper
+}
+
+package() {
+ cd $pkgname
+ install -Dm0755 uwm "$pkgdir/usr/bin/uwm"
+ install -Dm0755 contrib/uwm-helper "$pkgdir/usr/bin/uwm-helper"
+ install -Dm0644 uwm.1 "$pkgdir/usr/share/man/man1/uwm.1"
+ install -Dm0644 uwmrc.5 "$pkgdir/usr/share/man/man5/uwmrc.5"
+ install -Dm0644 contrib/uwmrc.example "$pkgdir/usr/share/X11/uwm/system.uwmrc"
+ install -Dm0644 contrib/uwm16x16.xpm "$pkgdir/usr/share/pixmaps/uwm16x16.xpm"
+ cd "$srcdir"
+ install -Dm0644 uwm.desktop "$pkgdir/usr/share/xsessions/uwm.desktop"
+}
+
+
+# vim: set sw=2 et:
diff --git a/arrayextern.patch b/arrayextern.patch
new file mode 100644
index 000000000000..476abbeceec2
--- /dev/null
+++ b/arrayextern.patch
@@ -0,0 +1,51 @@
+diff --git a/core-array.c b/core-array.c
+index 906e6a1..ad0b844 100644
+--- a/core-array.c
++++ b/core-array.c
+@@ -296,35 +296,34 @@ static const int ArrayBurstSize = 256;
+
+ // -------------------------------------------------------------------------
+
+-extern inline void *AllocMem(size_t);
+-extern inline void FreeMem(void *, size_t);
+-
+-#ifndef AllocMem
+-
++#ifdef AllocMem
++extern
++#else
++static
++#endif
+ /**
+ ** better malloc
+ **
+ ** @param size size of memory area to allocate
+ */
+-static inline void *AllocMem(size_t size)
++inline void *AllocMem(size_t size)
+ {
+ return malloc(size);
+ }
+
++#ifdef FreeMem
++extern
++#else
++static
+ #endif
+-
+-#ifndef FreeMem
+-
+ /**
+ ** better free
+ */
+-static inline void FreeMem(void *data, __attribute__ ((unused)) size_t size)
++inline void FreeMem(void *data, __attribute__ ((unused)) size_t size)
+ {
+ free(data);
+ }
+
+-#endif
+-
+ // -------------------------------------------------------------------------
+ // Helper functions
+
diff --git a/uwm.desktop b/uwm.desktop
new file mode 100644
index 000000000000..aacba97465f3
--- /dev/null
+++ b/uwm.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=μwm
+Comment=Micro (μ) Window Manger
+Exec=uwm
+Terminal=false
+Type=XSession
+Icon=uwm16x16
+
+[Window Manager]
+SessionManaged=false
+X-XDE-Managed=true