summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorimoutocon2020-02-08 22:52:26 -0500
committerimoutocon2020-02-08 22:52:26 -0500
commit0738ac71c6331743e3d61161a5aedbc55501f716 (patch)
tree8c7f6302e0bd53130fc375f7f9cac857979340d3
downloadaur-0738ac71c6331743e3d61161a5aedbc55501f716.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52db2f562624
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = uwu
+ pkgdesc = uwu your terminal today!
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://git.niichan.moe/98WuG/uwu
+ arch = x86_64
+ license = GPL
+ makedepends = gcc
+ depends = glibc
+ source = https://git.niichan.moe/98WuG/uwu/archive/0.1.tar.gz
+ md5sums = e8a17d4b4b927e6265d456eb4cbc09b1
+
+pkgname = uwu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cec5d850448e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: imoutocon <mail@niichan.moe>
+pkgname=uwu
+pkgver=0.1
+pkgrel=1
+pkgdesc="uwu your terminal today!"
+arch=('x86_64')
+url="https://git.niichan.moe/98WuG/uwu"
+license=('GPL')
+depends=('glibc')
+makedepends=('gcc')
+checkdepends=()
+changelog=
+source=("https://git.niichan.moe/98WuG/${pkgname}/archive/${pkgver}.tar.gz")
+noextract=()
+md5sums=("e8a17d4b4b927e6265d456eb4cbc09b1")
+validpgpkeys=()
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p $pkgdir/usr/bin
+ install -Dm755 uwu "$pkgdir/usr/bin/$pkgname"
+}