diff options
author | zxp19821005 | 2024-03-06 09:05:19 +0800 |
---|---|---|
committer | zxp19821005 | 2024-03-06 09:05:19 +0800 |
commit | a4d4b8f59134537a9e3d8445ff4afd2fe051bce1 (patch) | |
tree | d9e5fa37b1648cfe28d4c0639d69a56eb1238d4f | |
parent | b32e4624132b06e6590fc353c3624662f615013b (diff) | |
download | aur-a4d4b8f59134537a9e3d8445ff4afd2fe051bce1.tar.gz |
fix errors
-rw-r--r-- | .SRCINFO | 9 | ||||
-rw-r--r-- | PKGBUILD | 9 | ||||
-rw-r--r-- | uyou-todo.sh | 3 |
3 files changed, 8 insertions, 13 deletions
@@ -1,15 +1,12 @@ pkgbase = uyou-todo-bin pkgdesc = A todo list with electron pkgver = 2.1.1 - pkgrel = 2 + pkgrel = 3 url = https://github.com/tonylu110/uyou-todo-electron arch = x86_64 license = MIT - makedepends = squashfuse + makedepends = fuse2 depends = electron26 - depends = dbus-glib - depends = libdbusmenu-glib - depends = gtk2 provides = uyou-todo=2.1.1 conflicts = uyou-todo source = uyou-todo-2.1.1.AppImage::https://github.com/tonylu110/uyou-todo-electron/releases/download/2.1.1/uyou.ToDo-2.1.1.AppImage @@ -17,6 +14,6 @@ pkgbase = uyou-todo-bin source = uyou-todo.sh sha256sums = 2d3870d1b349a2a14292dd88a334c2f516c6e4810afc59daa62fd68064aed174 sha256sums = 39db5a38eec57377569ab296b6a804062b8e7a72908db228ae1d6d91bcbb61d3 - sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014 + sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe pkgname = uyou-todo-bin @@ -3,7 +3,7 @@ pkgname=uyou-todo-bin _pkgname=uyoutodo pkgver=2.1.1 _electronversion=26 -pkgrel=2 +pkgrel=3 pkgdesc="A todo list with electron" arch=('x86_64') url="https://github.com/tonylu110/uyou-todo-electron" @@ -12,12 +12,9 @@ provides=("${pkgname%-bin}=${pkgver}") conflicts=("${pkgname%-bin}") depends=( "electron${_electronversion}" - 'dbus-glib' - 'libdbusmenu-glib' - 'gtk2' ) makedepends=( - 'squashfuse' + 'fuse2' ) source=( "${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/${pkgver}/uyou.ToDo-${pkgver}.AppImage" @@ -26,7 +23,7 @@ source=( ) sha256sums=('2d3870d1b349a2a14292dd88a334c2f516c6e4810afc59daa62fd68064aed174' '39db5a38eec57377569ab296b6a804062b8e7a72908db228ae1d6d91bcbb61d3' - '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014') + '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe') build() { sed -e "s|@electronversion@|${_electronversion}|" \ -e "s|@appname@|${pkgname%-bin}|g" \ diff --git a/uyou-todo.sh b/uyou-todo.sh index f9ced1432cfc..86cb3dc6a9bf 100644 --- a/uyou-todo.sh +++ b/uyou-todo.sh @@ -1,10 +1,11 @@ -#!/bin/sh +#!/bin/bash set -e _APPDIR="/usr/lib/@appname@" _RUNNAME="${_APPDIR}/@runname@" export PATH="${_APPDIR}:${PATH}" export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}" export ELECTRON_IS_DEV=0 +export ELECTRON_FORCE_IS_PACKAGED=true export NODE_ENV=production cd "${_APPDIR}" if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then |