summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaFr4nc32019-01-20 01:08:27 +0900
committerLaFr4nc32019-01-20 01:08:27 +0900
commitf131d86d02a6d98de6254b1d0579bd4bdf6d9192 (patch)
tree611fe9d1ac37ecb87554c701f8550c18aecfe947
downloadaur-f131d86d02a6d98de6254b1d0579bd4bdf6d9192.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD43
-rw-r--r--V2CMOD-Z.desktop10
-rwxr-xr-xv2cmod-z.sh3
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c924e255c78d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = v2cmod-z
+ pkgdesc = A 2ch/5ch and Twitter browser
+ pkgver = 2.19.1
+ pkgrel = 1
+ url = http://v2c.s50.xrea.com/
+ arch = any
+ license = custom
+ depends = bash
+ depends = java-environment
+ source = http://v2c.s50.xrea.com/V2C_2.11.4.tar.gz
+ source = V2CMOD-Z.desktop
+ source = v2cmod-z.sh
+ source = https://www.dropbox.com/s/cvmbdghcf9pumlt/V2CMOD-Z_2.19.1(R20190113).zip
+ source = https://www.dropbox.com/s/8peqlatop8ay2n8/v2c_api_patch_B11.25.1.2_poverty_Patch.zip
+ md5sums = 7e8915c4052eae46ffbee572b641deac
+ md5sums = c9cd792277a89d729e8d9e2cd3a999e3
+ md5sums = a67e56c497d030550e03f56e232f18d7
+ md5sums = 1ce8457bfc604210cbff81baa449aa8a
+ md5sums = 400bc9e17fba7b89f27aee0c145965e2
+
+pkgname = v2cmod-z
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06d8a360261a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: LaFr4nc3 <lafr4nc3 at gmail dot com>
+pkgname=v2cmod-z
+pkgver=2.19.1
+_reldate=20190113
+_b11ver=B11.25.1.2
+pkgrel=1
+pkgdesc="A 2ch/5ch and Twitter browser"
+arch=("any")
+url="http://v2c.s50.xrea.com/"
+license=("custom")
+depends=("bash" "java-environment")
+source=("http://v2c.s50.xrea.com/V2C_2.11.4.tar.gz"
+ "V2CMOD-Z.desktop"
+ "v2cmod-z.sh"
+ "https://www.dropbox.com/s/cvmbdghcf9pumlt/V2CMOD-Z_${pkgver}(R${_reldate}).zip"
+ "https://www.dropbox.com/s/8peqlatop8ay2n8/v2c_api_patch_${_b11ver}_poverty_Patch.zip")
+md5sums=("7e8915c4052eae46ffbee572b641deac"
+ "c9cd792277a89d729e8d9e2cd3a999e3"
+ "a67e56c497d030550e03f56e232f18d7"
+ "1ce8457bfc604210cbff81baa449aa8a"
+ "400bc9e17fba7b89f27aee0c145965e2")
+
+prepare() {
+ cd "${srcdir}/v2c/launcher"
+ cp -f "${srcdir}/V2CMOD-Z_${pkgver}(R${_reldate})/V2C_R20131210.jar" "./"
+ cp -f "${srcdir}/v2c_api_patch_${_b11ver}_poverty_Patch/v2c_api_patch_B11.jar" "./"
+ sed -e "s/V2C_R20131210.jar/v2c_api_patch_B11.jar/" "v2cjar.txt"
+}
+
+package() {
+ install -d "${pkgdir}/opt/v2cmod-z"
+ cp -r "${srcdir}/v2c/"{launcher,v2cicon.png} "${pkgdir}/opt/v2cmod-z"
+ install "${srcdir}/v2c/"{mkdticon,rmdticon,v2c} "${pkgdir}/opt/v2cmod-z"
+
+ install -d "${pkgdir}/usr/bin"
+ install "${srcdir}/v2cmod-z.sh" "${pkgdir}/usr/bin/v2cmod-z"
+
+ install -d "${pkgdir}/usr/share/applications"
+ cp "${srcdir}/V2CMOD-Z.desktop" "${pkgdir}/usr/share/applications"
+
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ touch "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/V2CMOD-Z.desktop b/V2CMOD-Z.desktop
new file mode 100644
index 000000000000..1c721aecfca1
--- /dev/null
+++ b/V2CMOD-Z.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=2.19.1-R20190113
+Name=V2CMOD-Z
+Comment=A 2ch/5ch and Twitter browser
+Path=/opt/v2cmod-z
+Exec=v2c
+Icon=v2cicon.png
+Terminal=false
+Categories=Network;Java
diff --git a/v2cmod-z.sh b/v2cmod-z.sh
new file mode 100755
index 000000000000..6fb9b5bf4a78
--- /dev/null
+++ b/v2cmod-z.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+/opt/v2cmod-z/v2c $@
+