summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDr. Incognito2020-02-21 11:11:17 +0800
committerDr. Incognito2020-02-21 11:11:17 +0800
commit5a6eae1334237335c50281d87ea572a12161d0e4 (patch)
tree54a36e6006f89844720e13d3da336821e9a97a6a
parent56e78658101eedafcb6662ca941379ded812ef59 (diff)
downloadaur-5a6eae1334237335c50281d87ea572a12161d0e4.tar.gz
Use qzxing@gitee.com to accelerates the clone process.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc1fdb416af4..b099eefc8f29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,12 +5,15 @@ pkgbase = v2ray-desktop
url = https://github.com/Dr-Incognito/V2Ray-Desktop
arch = x86_64
license = GPL3
- makedepends = git
- makedepends = make
+ makedepends = git>=2.11
makedepends = qt5-tools>=5.14.0
+ makedepends = qt5-declarative>=5.14.0
+ makedepends = curl
makedepends = which
makedepends = gcc
- makedepends = qt5-declarative>=5.14.0
+ makedepends = make
+ makedepends = jq
+ makedepends = sed
depends = v2ray
depends = qt5-base>=5.14.0
depends = qt5-quickcontrols>=5.14.0
diff --git a/PKGBUILD b/PKGBUILD
index dd0c619c61d4..51401148434e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,26 @@ arch=("x86_64")
url="https://github.com/Dr-Incognito/V2Ray-Desktop"
license=("GPL3")
depends=("v2ray" "qt5-base>=5.14.0" "qt5-quickcontrols>=5.14.0" "qt5-quickcontrols2>=5.14.0")
-makedepends=("git" "make" "qt5-tools>=5.14.0" which gcc "qt5-declarative>=5.14.0")
+makedepends=("git>=2.11" "qt5-tools>=5.14.0" "qt5-declarative>=5.14.0" curl which gcc make jq sed)
provides=(v2ray-desktop)
source=("V2Ray-Desktop::git+${url}#tag=${pkgver}")
sha512sums=("SKIP")
prepare() {
cd "${srcdir}/V2Ray-Desktop"
+
+ echo "Detecting your country ... Please wait ..."
+ country=$(curl -s https://ipvigilante.com/$(curl -s icanhazip.com) | jq -r '.data.country_name')
+ echo "Your country: $country"
+
+ if [ "$country" = "China" ]; then
+ echo "Use qzxing@gitee.com for Chinese users ..."
+ sed -i "s/github.com\/ftylitak/gitee.com\/Dr-Incognito/" .gitmodules
+ fi
+
echo "Initialize submodules. This may take a long time ..."
git submodule init
- git submodule update
+ git submodule update --progress
}
build() {