summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDr. Incognito2020-04-01 15:19:04 +0800
committerDr. Incognito2020-04-01 15:19:04 +0800
commitb2d03d458804ad7802827bd9098f31346649e88f (patch)
tree35efe77b4c0c1f1e6c58e839b98d4893551430df
parent0ad8b5433689de1ffc705191141cf1d922cf52c2 (diff)
downloadaur-b2d03d458804ad7802827bd9098f31346649e88f.tar.gz
Release v2.0.0.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 7 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2047d01aef1..c26685ee46af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = v2ray-desktop
pkgdesc = A Cross-platform GUI Client for V2Ray written in Qt 5 and QML 2 (Stable Release)
- pkgver = 1.5.2
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/Dr-Incognito/V2Ray-Desktop
arch = x86_64
@@ -8,14 +8,12 @@ pkgbase = v2ray-desktop
makedepends = git>=2.11
makedepends = qt5-tools>=5.14.0
makedepends = qt5-declarative>=5.14.0
- makedepends = curl
- makedepends = jq
- depends = v2ray
+ depends = clash
depends = qt5-base>=5.14.0
depends = qt5-quickcontrols>=5.14.0
depends = qt5-quickcontrols2>=5.14.0
provides = v2ray-desktop
- source = V2Ray-Desktop::git+https://github.com/Dr-Incognito/V2Ray-Desktop#tag=1.5.2
+ source = V2Ray-Desktop::git+https://github.com/Dr-Incognito/V2Ray-Desktop#tag=2.0.0
sha512sums = SKIP
pkgname = v2ray-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 6039b780cc57..a7df93d7ba15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Dr-Incognito <v2ray.dev at gmail dot com>
pkgname=v2ray-desktop
-pkgver=1.5.2
+pkgver=2.0.0
pkgrel=1
pkgdesc="A Cross-platform GUI Client for V2Ray written in Qt 5 and QML 2 (Stable Release)"
arch=("x86_64")
url="https://github.com/Dr-Incognito/V2Ray-Desktop"
license=("GPL3")
-depends=("v2ray" "qt5-base>=5.14.0" "qt5-quickcontrols>=5.14.0" "qt5-quickcontrols2>=5.14.0")
-makedepends=("git>=2.11" "qt5-tools>=5.14.0" "qt5-declarative>=5.14.0" curl jq)
+depends=("clash" "qt5-base>=5.14.0" "qt5-quickcontrols>=5.14.0" "qt5-quickcontrols2>=5.14.0")
+makedepends=("git>=2.11" "qt5-tools>=5.14.0" "qt5-declarative>=5.14.0")
provides=(v2ray-desktop)
source=("V2Ray-Desktop::git+${url}#tag=${pkgver}")
sha512sums=("SKIP")
@@ -15,15 +15,7 @@ sha512sums=("SKIP")
prepare() {
cd "${srcdir}/V2Ray-Desktop"
- echo "Detecting your country ... Please wait ..."
- country=$(curl -s https://ipvigilante.com/$(curl -s icanhazip.com) | jq -r '.data.country_name')
- echo "Your country: $country"
-
- if [ "$country" = "China" ]; then
- echo "Use qzxing@gitee.com for Chinese users ..."
- sed -i "s/github.com\/ftylitak/gitee.com\/Dr-Incognito/" .gitmodules
- fi
-
+ sed -i "s/github.com\/ftylitak/gitee.com\/Dr-Incognito/" .gitmodules
echo "Initialize submodules. This may take a long time ..."
git submodule init
git submodule update --progress