summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDr. Incognito2020-04-02 10:19:43 +0800
committerDr. Incognito2020-04-02 10:19:43 +0800
commitb325120b225bd83ace92998a6eb8f0f5214bb3d7 (patch)
treebe7706bbdbb1a40187c2d5a6bf9f81cdfdad2297
parent157e3addceaf16aefea05e37dbddd7a0dc082111 (diff)
downloadaur-b325120b225bd83ace92998a6eb8f0f5214bb3d7.tar.gz
Fix some bugs for PKGBUILD.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d645bdfe92b1..f8b55d699b4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,13 +5,14 @@ pkgbase = v2ray-desktop
url = https://github.com/Dr-Incognito/V2Ray-Desktop
arch = x86_64
license = GPL3
- makedepends = git>=2.11
+ makedepends = git
makedepends = qt5-tools>=5.14.0
makedepends = qt5-declarative>=5.14.0
depends = clash
depends = qt5-base>=5.14.0
depends = qt5-quickcontrols>=5.14.0
depends = qt5-quickcontrols2>=5.14.0
+ depends = qt5-svg>=5.14.0
provides = v2ray-desktop
source = V2Ray-Desktop::git+https://github.com/Dr-Incognito/V2Ray-Desktop#tag=2.0.1
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 567d15dd6332..60680aa15fd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@ pkgdesc="A cross-platform GUI proxy client that supports Shadowsocks, V2Ray, and
arch=("x86_64")
url="https://github.com/Dr-Incognito/V2Ray-Desktop"
license=("GPL3")
-depends=("clash" "qt5-base>=5.14.0" "qt5-quickcontrols>=5.14.0" "qt5-quickcontrols2>=5.14.0")
-makedepends=("git>=2.11" "qt5-tools>=5.14.0" "qt5-declarative>=5.14.0")
+depends=("clash" "qt5-base>=5.14.0" "qt5-quickcontrols>=5.14.0" "qt5-quickcontrols2>=5.14.0" "qt5-svg>=5.14.0")
+makedepends=("git" "qt5-tools>=5.14.0" "qt5-declarative>=5.14.0")
provides=(v2ray-desktop)
source=("V2Ray-Desktop::git+${url}#tag=${pkgver}")
sha512sums=("SKIP")
@@ -15,7 +15,14 @@ sha512sums=("SKIP")
prepare() {
cd "${srcdir}/V2Ray-Desktop"
- sed -i "s/github.com\/ftylitak/gitee.com\/Dr-Incognito/" .gitmodules
+ echo "Detecting your country ... Please wait ..."
+ country=$(curl -s https://ipinfo.io/ | jq -r '.country')
+ echo "Your country: $country"
+
+ if [ "$country" = "CN" ]; then
+ echo "Use qzxing@gitee.com for Chinese users ..."
+ sed -i "s/github.com\/ftylitak/gitee.com\/Dr-Incognito/" .gitmodules
+ fi
echo "Initialize submodules. This may take a long time ..."
git submodule init
git submodule update --progress