summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDictator Mei2018-08-01 00:12:22 +0900
committerDictator Mei2018-08-01 00:12:22 +0900
commit38f19154444fbf21c9a3442a962b1d6a056683c1 (patch)
tree6812b3b751ce4cfc3ab509f0359132fe308fb6ea
parent9692914bf4ad6ab5bf2b338ca6ae342e60c272f7 (diff)
downloadaur-38f19154444fbf21c9a3442a962b1d6a056683c1.tar.gz
update service
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--v2ray.service13
3 files changed, 21 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54cd48c26548..f402fc81da04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = v2ray-git
pkgdesc = A platform for building proxies to bypass network restrictions
- pkgver = 3.23
- pkgrel = 4
+ pkgver = 3.33
+ pkgrel = 1
url = https://github.com/v2ray/v2ray-core
arch = x86_64
license = MIT
@@ -12,7 +12,7 @@ pkgbase = v2ray-git
source = git+https://github.com/v2ray/v2ray-core.git
source = v2ray.service
sha512sums = SKIP
- sha512sums = bebb87f43b3920be8efde9aece9c4305323cd7d3a65a3b2441f0dbd0098c02a18ca89a5b08833eee70482cffae2c8e7b7237bb5a4d1076e3c30d273898e2bedb
+ sha512sums = ddc63b48b1f660bf93447c300fca21a30a893b062e87d6ca730326e09f3bac418a1647c0de8544ab8939ff535aa7a537aa62d4ff4373f1b5ed2721844e3b8ab0
pkgname = v2ray-git
diff --git a/PKGBUILD b/PKGBUILD
index aeb1f661838f..cf00460f1d89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: pandada8 <pandada8@gmail.com>
pkgname=v2ray-git
-pkgver=3.23
-pkgrel=4
+pkgver=3.33
+pkgrel=1
pkgdesc="A platform for building proxies to bypass network restrictions"
-arch=("x86_64")
+arch=('x86_64')
url="https://github.com/v2ray/v2ray-core"
-license=("MIT")
+license=('MIT')
makedepends=("git" "go")
-provides=("v2ray")
-conflicts=("v2ray")
+provides=('v2ray')
+conflicts=('v2ray')
source=("git+${url}.git"
"v2ray.service")
sha512sums=("SKIP"
- "bebb87f43b3920be8efde9aece9c4305323cd7d3a65a3b2441f0dbd0098c02a18ca89a5b08833eee70482cffae2c8e7b7237bb5a4d1076e3c30d273898e2bedb")
+ "ddc63b48b1f660bf93447c300fca21a30a893b062e87d6ca730326e09f3bac418a1647c0de8544ab8939ff535aa7a537aa62d4ff4373f1b5ed2721844e3b8ab0")
pkgver() {
git -C v2ray-core describe | sed -e 's/^v//' -e 's/-/./g'
diff --git a/v2ray.service b/v2ray.service
index 243644487db5..da29747dedbc 100644
--- a/v2ray.service
+++ b/v2ray.service
@@ -4,10 +4,19 @@ After=network.target
Wants=network.target
[Service]
+# This service runs as root. You may consider to run it as another use for security concerns.
+# By uncommenting the following two lines, this service will run as user v2ray/v2ray.
+# More discussion at https://github.com/v2ray/v2ray-core/issues/1011
+# User=v2ray
+# Group=v2ray
Type=simple
-PIDFile=/var/run/v2ray-%i.pid
-ExecStart=/usr/bin/env v2ray.location.asset=/etc/v2ray /usr/bin/v2ray -config /etc/v2ray/%i.json
+PIDFile=/var/run/v2ray.pid
+ExecStart=V2RAY_VMESS_PADDING=1 /usr/bin/env v2ray.location.asset=/etc/v2ray /usr/bin/v2ray -config /etc/v2ray/config.json
Restart=on-failure
+# Don't restart in the case of configuration error
+RestartPreventExitStatus=23
+# After unexpected exit, upload latest V2Ray log to official log service for future analysis.
+# ExecStopPost=/usr/bin/v2ray/upload.sh
[Install]
WantedBy=multi-user.target