summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDictator Mei2018-08-01 13:02:19 +0900
committerDictator Mei2018-08-01 13:02:19 +0900
commitf731130106888d739cfb1b9d4deae1e198cd2034 (patch)
treeaee89a8803ec42aa50eeeed34348934854be3b8d
parent38f19154444fbf21c9a3442a962b1d6a056683c1 (diff)
downloadaur-f731130106888d739cfb1b9d4deae1e198cd2034.tar.gz
fix
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--v2ray.service13
3 files changed, 5 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f402fc81da04..c4ed678e7b11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = v2ray-git
source = git+https://github.com/v2ray/v2ray-core.git
source = v2ray.service
sha512sums = SKIP
- sha512sums = ddc63b48b1f660bf93447c300fca21a30a893b062e87d6ca730326e09f3bac418a1647c0de8544ab8939ff535aa7a537aa62d4ff4373f1b5ed2721844e3b8ab0
+ sha512sums = 2fbdea0017f513d3b806dfc33c6296d8521b3241f46078d0b18a3d6571d8331e5c49ba168522ba924ae9d12837422b36f6aa9dff3d107fb4d5ee087b14a58e6f
pkgname = v2ray-git
diff --git a/PKGBUILD b/PKGBUILD
index cf00460f1d89..13b5c9140dac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ conflicts=('v2ray')
source=("git+${url}.git"
"v2ray.service")
sha512sums=("SKIP"
- "ddc63b48b1f660bf93447c300fca21a30a893b062e87d6ca730326e09f3bac418a1647c0de8544ab8939ff535aa7a537aa62d4ff4373f1b5ed2721844e3b8ab0")
+ "2fbdea0017f513d3b806dfc33c6296d8521b3241f46078d0b18a3d6571d8331e5c49ba168522ba924ae9d12837422b36f6aa9dff3d107fb4d5ee087b14a58e6f")
pkgver() {
git -C v2ray-core describe | sed -e 's/^v//' -e 's/-/./g'
@@ -43,7 +43,7 @@ package() {
cd v2ray-core
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/v2ray/LICENSE
install -Dm644 release/config/systemd/v2ray.service ${pkgdir}/usr/lib/systemd/system/v2ray.service
- sed -i '/ExecStart/c\ExecStart=/usr/bin/env v2ray.location.asset=/etc/v2ray /usr/bin/v2ray -config /etc/v2ray/config.json' "$pkgdir"/usr/lib/systemd/system/v2ray.service
+ sed -i '/ExecStart/c\ExecStart=V2RAY_VMESS_PADDING=1 /usr/bin/env v2ray.location.asset=/etc/v2ray /usr/bin/v2ray -config /etc/v2ray/config.json' "$pkgdir"/usr/lib/systemd/system/v2ray.service
install -Dm644 release/config/geoip.dat release/config/geosite.dat release/config/*.json -t "$pkgdir"/etc/v2ray/
install -Dm755 "$GOPATH"/bin/v2ray-custom-linux-64/{v2ray,v2ctl} -t "$pkgdir"/usr/bin/
diff --git a/v2ray.service b/v2ray.service
index da29747dedbc..a41e28a5a93c 100644
--- a/v2ray.service
+++ b/v2ray.service
@@ -4,19 +4,10 @@ After=network.target
Wants=network.target
[Service]
-# This service runs as root. You may consider to run it as another use for security concerns.
-# By uncommenting the following two lines, this service will run as user v2ray/v2ray.
-# More discussion at https://github.com/v2ray/v2ray-core/issues/1011
-# User=v2ray
-# Group=v2ray
Type=simple
-PIDFile=/var/run/v2ray.pid
-ExecStart=V2RAY_VMESS_PADDING=1 /usr/bin/env v2ray.location.asset=/etc/v2ray /usr/bin/v2ray -config /etc/v2ray/config.json
+PIDFile=/var/run/v2ray-%i.pid
+ExecStart=V2RAY_VMESS_PADDING=1 /usr/bin/env v2ray.location.asset=/etc/v2ray /usr/bin/v2ray -config /etc/v2ray/%i.json
Restart=on-failure
-# Don't restart in the case of configuration error
-RestartPreventExitStatus=23
-# After unexpected exit, upload latest V2Ray log to official log service for future analysis.
-# ExecStopPost=/usr/bin/v2ray/upload.sh
[Install]
WantedBy=multi-user.target