summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorm8D22019-07-13 07:02:30 -0700
committerm8D22019-07-13 07:02:30 -0700
commit4d23600765d0e9b2012514989d9e4844aa6bbbb7 (patch)
tree0c03762ad31b1061636d241e6d3e46f8db93e70c
parentb7ed34e568b6ee615f99a5f25807d9135f9eaf35 (diff)
downloadaur-4d23600765d0e9b2012514989d9e4844aa6bbbb7.tar.gz
Cleaning up of PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD46
2 files changed, 24 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3db63de371d4..4248effc401e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
-# Generated by mksrcinfo v8
-# Sat Jan 26 16:00:43 UTC 2019
pkgbase = v2ray-plugin-git
- pkgdesc = Yet another SIP003 plugin for shadowsocks, based on v2ray (git version)
- pkgver = v1.0.r3.g4f8b2c5
+ pkgdesc = A SIP003 plugin based on v2ray for shadowsocks (git version)
+ pkgver = 1.1.0.r7.gc7017f4
pkgrel = 1
url = https://github.com/shadowsocks/v2ray-plugin
arch = x86_64
license = MIT
- makedepends = go
+ makedepends = go-pie
makedepends = git
+ depends = glibc
conflicts = v2ray-plugin
+ conflicts = shadowsocks-v2ray-plugin
source = v2ray-plugin-git::git+https://github.com/shadowsocks/v2ray-plugin.git
- source = https://raw.githubusercontent.com/shadowsocks/v2ray-plugin/master/LICENSE
sha256sums = SKIP
- sha256sums = d903af2e15f43ddc5782ec20a0f1bdd090974ebea01ab02e0b015b76283ea666
pkgname = v2ray-plugin-git
diff --git a/PKGBUILD b/PKGBUILD
index 835ef20dba79..15e62835aa50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,33 @@
+# Maintainer: m8D2 <omui (at) proton mail (dot) com>
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Maintainer: LIN Ruohshoei <lin dot ruohshoei plus archlinux at gmail dot com>
pkgname=v2ray-plugin-git
-_pkgname=v2ray-plugin
-pkgver=v1.0.r3.g4f8b2c5
+pkgver=1.1.0.r7.gc7017f4
pkgrel=1
-pkgdesc='Yet another SIP003 plugin for shadowsocks, based on v2ray (git version)'
-arch=('x86_64')
+pkgdesc='A SIP003 plugin based on v2ray for shadowsocks (git version)'
+arch=(x86_64)
url='https://github.com/shadowsocks/v2ray-plugin'
-license=('MIT')
-#depends=('' '')
-makedepends=('go' 'git')
-conflicts=('v2ray-plugin')
-source=("$pkgname::git+https://github.com/shadowsocks/${_pkgname}.git"
- "https://raw.githubusercontent.com/shadowsocks/v2ray-plugin/master/LICENSE")
-sha256sums=('SKIP'
- 'd903af2e15f43ddc5782ec20a0f1bdd090974ebea01ab02e0b015b76283ea666')
+license=(MIT)
+depends=(glibc)
+makedepends=(go-pie git)
+conflicts=(v2ray-plugin shadowsocks-v2ray-plugin)
+source=("$pkgname::git+https://github.com/shadowsocks/v2ray-plugin.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- # cutting off 'foo-' prefix that presents in the git tag
- git describe --long --tags | sed 's/^foo-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$pkgname"
+
+ # cutting off 'v' prefix that presents in the git tag
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- export GOPATH="$srcdir"/gopath
- cd $srcdir/$pkgname
- go get -u -v github.com/shadowsocks/v2ray-plugin
- go build -v \
- -gcflags "all=-trimpath=$PWD" \
- -asmflags "all=-trimpath=$PWD" \
- -ldflags "-extldflags $LDFLAGS" \
- -o $pkgname .
+ cd "$srcdir"/$pkgname
+ go build
}
package() {
- cd $srcdir/$pkgname
- install -Dm755 $pkgname "$pkgdir"/usr/bin/$_pkgname
- install -vDm644 LICENSE -t ${pkgdir}/usr/share/licenses/$_pkgname
- echo "README FILE: https://github.com/shadowsocks/v2ray-plugin/blob/master/README.md"
+ cd "$srcdir"/$pkgname
+ install -Dm755 v2ray-plugin "$pkgdir"/usr/bin/v2ray-plugin
}