summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2017-12-22 18:29:52 +0100
committeraksr2017-12-22 18:29:52 +0100
commitd9ba91b3611f151ea8f6bbe7e04f3850f12b8593 (patch)
treed752d503c767e5b6db258ecb0c8d6c1e201c3ac4
parent8e94898701d51b10f17830d2fc661937bbef0991 (diff)
downloadaur-d9ba91b3611f151ea8f6bbe7e04f3850f12b8593.tar.gz
Update.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cda9de9c4495..beab2b542ecd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
# Generated by mksrcinfo v8
-# Sun Apr 24 13:28:48 UTC 2016
+# Fri Dec 22 17:29:47 UTC 2017
pkgbase = v6shell-git
pkgdesc = V6 Thompson Shell Port
- pkgver = 4.2.0.r3.gc2c95b6
+ pkgver = 4.9.0.r14.g667288b
pkgrel = 1
url = https://github.com/JNeitzel/v6shell
arch = i686
arch = x86_64
license = custom
makedepends = git
- source = v6shell-git::git://github.com/JNeitzel/v6shell.git
+ source = v6shell-git::git+https://github.com/JNeitzel/v6shell.git
+ source = v6scripts::git+https://github.com/JNeitzel/v6scripts.git
+ md5sums = SKIP
md5sums = SKIP
pkgname = v6shell-git
diff --git a/PKGBUILD b/PKGBUILD
index 79159d0040db..44c18820f455 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: aksr <aksr at t-com dot me>
pkgname=v6shell-git
-pkgver=4.2.0.r3.gc2c95b6
+pkgver=4.9.0.r14.g667288b
pkgrel=1
epoch=
pkgdesc="V6 Thompson Shell Port"
@@ -20,24 +20,29 @@ backup=()
options=()
changelog=
install=
-source=("$pkgname::git://github.com/JNeitzel/v6shell.git")
+source=("$pkgname::git+https://github.com/JNeitzel/v6shell.git"
+ "v6scripts::git+https://github.com/JNeitzel/v6scripts.git")
noextract=()
-md5sums=('SKIP')
+md5sums=('SKIP' 'SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^v//'
}
build() {
cd "$srcdir/$pkgname"
+ ./configure
make
}
package() {
cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir/" PREFIX=/usr LIBEXECDIR=/usr/bin install
- install -Dm644 README $pkgdir/usr/share/doc/$pkgname/README
- install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+ install -Dm644 README $pkgdir/usr/share/doc/${pkgname%-*}/README
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
+ cd "$srcdir/v6scripts"
+ mkdir -p "$pkgdir/usr/share/doc/${pkgname%-*}/scripts"
+ cp -a * "$pkgdir/usr/share/doc/${pkgname%-*}/scripts"
}