summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2016-08-23 22:35:10 +0200
committerMarco Pompili2016-08-23 22:35:10 +0200
commit5e0d7c012a5eb76cd9675644356e51e7850926f6 (patch)
treee24abf73bbcf98a8ccb8aae2a1a5cd9e1aed39b9
parentbf6b6f3d5c7a05eb9f028adc118575c5854f387a (diff)
downloadaur-5e0d7c012a5eb76cd9675644356e51e7850926f6.tar.gz
Version 5.4.374.1-2, switched to gn
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD44
2 files changed, 32 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 066a6bee5601..0165d57be170 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Aug 10 12:01:25 UTC 2016
+# Tue Aug 23 20:33:45 UTC 2016
pkgbase = v8
pkgdesc = Fast and modern Javascript engine used in Google Chrome.
pkgver = 5.4.374.1
- pkgrel = 1
+ pkgrel = 2
url = https://code.google.com/p/v8/
arch = i686
arch = x86_64
@@ -16,6 +16,10 @@ pkgbase = v8
depends = readline
depends = icu
depends = ncurses5-compat-libs
+ conflicts = v8-5.2
+ conflicts = v8-3.14
+ conflicts = v8-3.15
+ conflicts = v8-3.20
source = depot_tools::git+https://chromium.googlesource.com/chromium/tools/depot_tools.git
source = gyp::git+https://chromium.googlesource.com/external/gyp
source = v8.pc
diff --git a/PKGBUILD b/PKGBUILD
index f88c61e0764c..082d441373d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,14 @@
pkgname=v8
pkgver=5.4.374.1
-pkgrel=1
+pkgrel=2
pkgdesc="Fast and modern Javascript engine used in Google Chrome."
-arch=("i686" "x86_64")
+arch=('i686' 'x86_64')
url="https://code.google.com/p/v8/"
-license=("BSD")
-depends=("readline" "icu" "ncurses5-compat-libs")
-makedepends=("clang-tools-extra" "python2" "python2-virtualenv" "ninja" "git")
+license=('BSD')
+depends=('readline' 'icu' 'ncurses5-compat-libs')
+makedepends=('clang-tools-extra' 'python2' 'python2-virtualenv' 'ninja' 'git')
+conflicts=('v8-5.2' 'v8-3.14' 'v8-3.15' 'v8-3.20')
source=("depot_tools::git+https://chromium.googlesource.com/chromium/tools/depot_tools.git"
"gyp::git+https://chromium.googlesource.com/external/gyp"
"v8.pc"
@@ -61,18 +62,29 @@ prepare() {
build() {
cd v8
- export GYP_GENERATORS=ninja
- msg2 "Running gyp..."
- gypfiles/gyp_v8
+ msg2 "Running GN..."
+ tools/dev/v8gen.py x64.release
+
+ ## Needs to resync after running GN
+ msg2 "Resyncing..."
+ gclient sync
msg2 "Start building..."
- ninja -C out/Release all # or target 'v8 d8' if you do not need tests
+ ninja -C out.gn/x64.release
}
check() {
cd v8
- tools/run-tests.py --no-presubmit --outdir=out --buildbot --arch=$V8_ARCH --mode=Release # --progress=dots
+ ## run-tests.py seems not to digest the folder x64.release
+ ## so we make a link called release in the src folder (./)
+ ln -s out.gn/x64.release release
+
+ tools/run-tests.py --no-presubmit \
+ --outdir=. \
+ --buildbot \
+ --arch=$V8_ARCH \
+ --mode=release # --progress=dots
}
package() {
@@ -80,22 +92,18 @@ package() {
install -d $pkgdir/usr/lib/v8
- install -Dm755 out/Release/d8 $pkgdir/usr/lib/v8/d8
- install -Dm644 out/Release/natives_blob.bin $pkgdir/usr/lib/v8/natives_blob.bin
- install -Dm644 out/Release/snapshot_blob.bin $pkgdir/usr/lib/v8/snapshot_blob.bin
- #install -Dm755 out/Release/lib/libv8.so $pkgdir/usr/lib/v8/libv8.so
- #ln -s v8/libv8.so $pkgdir/usr/lib/libv8.so
+ install -Dm755 out.gn/x64.release/d8 $pkgdir/usr/lib/v8/d8
+ install -Dm644 out.gn/x64.release/natives_blob.bin $pkgdir/usr/lib/v8/natives_blob.bin
+ install -Dm644 out.gn/x64.release/snapshot_blob.bin $pkgdir/usr/lib/v8/snapshot_blob.bin
install -Dm755 $srcdir/d8 $pkgdir/usr/bin/d8
-
# V8 has several header files and ideally if it had its own folder in /usr/include
# But doing it here will break all users. Ideally if they use provided pkgconfig file.
install -d $pkgdir/usr/include
install -Dm644 include/*.h $pkgdir/usr/include
install -d $pkgdir/usr/share/v8
- install -Dm644 $srcdir/v8/out/Release/obj/src/*.a $pkgdir/usr/share/v8
-
+
install -d $pkgdir/usr/lib/pkgconfig
install -m644 $srcdir/v8.pc $pkgdir/usr/lib/pkgconfig