summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2017-12-02 17:32:41 +0100
committerMarco Pompili2017-12-02 17:32:41 +0100
commit6b78cc99e3cfc8160c913ba8ffdb90de0ca5ead7 (patch)
tree3d80819f6ce59b64a8913aa7792405555e45ad58
parent483a014297f8165ae2463ede1cfc1fbe9a5b91b1 (diff)
downloadaur-6b78cc99e3cfc8160c913ba8ffdb90de0ca5ead7.tar.gz
Version 6.4.388.2-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--ctest.patch27
3 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ba54da9012e..3c6277c28784 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Aug 30 14:34:19 UTC 2017
+# Sat Dec 2 16:26:44 UTC 2017
pkgbase = v8
pkgdesc = Fast and modern Javascript engine used in Google Chrome.
- pkgver = 6.0.286.57
+ pkgver = 6.4.388.2
pkgrel = 1
url = https://code.google.com/p/v8/
arch = i686
@@ -35,7 +35,7 @@ pkgbase = v8
sha256sums = ae23d543f655b4d8449f98828d0aff6858a777429b9ebdd2e23541f89645d4eb
sha256sums = 6abb07ab1cf593067d19028f385bd7ee52196fc644e315c388f08294d82ceff0
sha256sums = 3a67793d1a7a93cec00f2693f11e79749364d2541edfb99d0be3f9c132382d1f
- sha256sums = 14ee52de490515d23fe14376258921d45c45a4011b5cd3344cde026d8b494774
+ sha256sums = db2f7e8b37d99a396b488d7657d6febb475371d42ec30fff8ffbb69983a9a09f
pkgname = v8
diff --git a/PKGBUILD b/PKGBUILD
index c7d4cee11f6f..3c0bf1143d0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Marco Pompili <aur (at) emarcs (dot) org>
+# Maintainer: Marco Pompili <aur (at) mg.odd.red>
# Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
# Contributor: Kaiting Chen <kaitocracy@gmail.com>
@@ -6,7 +6,7 @@
# Contributor: David Flemström <david.flemstrom@gmail.com>
pkgname=v8
-pkgver=6.0.286.57
+pkgver=6.4.388.2
pkgrel=1
pkgdesc="Fast and modern Javascript engine used in Google Chrome."
arch=('i686' 'x86_64')
@@ -28,7 +28,7 @@ sha256sums=('SKIP'
'ae23d543f655b4d8449f98828d0aff6858a777429b9ebdd2e23541f89645d4eb'
'6abb07ab1cf593067d19028f385bd7ee52196fc644e315c388f08294d82ceff0'
'3a67793d1a7a93cec00f2693f11e79749364d2541edfb99d0be3f9c132382d1f'
- '14ee52de490515d23fe14376258921d45c45a4011b5cd3344cde026d8b494774')
+ 'db2f7e8b37d99a396b488d7657d6febb475371d42ec30fff8ffbb69983a9a09f')
#
@@ -116,8 +116,8 @@ prepare() {
msg2 "Using system libraries for ICU"
./build/linux/unbundle/replace_gn_files.py --system-libraries icu
- msg2 "Applying gcc7 compatibility patch"
- patch -p1 -i ${srcdir}/gcc7.patch
+ #msg2 "Applying gcc7 compatibility patch"
+ #patch -p1 -i ${srcdir}/gcc7.patch
msg "Applying ctest patch"
patch -p1 -i ${srcdir}/ctest.patch
@@ -163,7 +163,7 @@ check() {
cd v8
- msg2 "Testing, this will take also a while..."
+ msg2 "Testing, this will also take a while..."
tools/run-tests.py --no-presubmit \
--outdir=out.gn \
--buildbot \
diff --git a/ctest.patch b/ctest.patch
index 8ba268f6dcc7..1c6441a0d62b 100644
--- a/ctest.patch
+++ b/ctest.patch
@@ -1,5 +1,17 @@
+diff --git a/test/cctest/BUILD.gn b/test/cctest/BUILD.gn
+index ca81ef1f0d..0f90d99f60 100644
+--- a/test/cctest/BUILD.gn
++++ b/test/cctest/BUILD.gn
+@@ -205,7 +205,6 @@ v8_source_set("cctest_sources") {
+ "test-typedarrays.cc",
+ "test-types.cc",
+ "test-unbound-queue.cc",
+- "test-unboxed-doubles.cc",
+ "test-unscopables-hidden-prototype.cc",
+ "test-usecounters.cc",
+ "test-utils.cc",
diff --git a/test/cctest/compiler/graph-builder-tester.h b/test/cctest/compiler/graph-builder-tester.h
-index a2436ad1d2..5305060896 100644
+index 1bf1d40587..7a2559a126 100644
--- a/test/cctest/compiler/graph-builder-tester.h
+++ b/test/cctest/compiler/graph-builder-tester.h
@@ -168,9 +168,6 @@ class GraphBuilderTester : public HandleAndZoneScope,
@@ -12,16 +24,3 @@ index a2436ad1d2..5305060896 100644
Node* ChangeTaggedToBit(Node* a) {
return NewNode(simplified()->ChangeTaggedToBit(), a);
}
-diff --git a/test/cctest/BUILD.gn b/test/cctest/BUILD.gn
-index d5365df606..c39b1bc46c 100644
---- a/test/cctest/BUILD.gn
-+++ b/test/cctest/BUILD.gn
-@@ -177,6 +177,6 @@ v8_executable("cctest") {
- "test-typedarrays.cc",
- "test-types.cc",
- "test-unbound-queue.cc",
-- "test-unboxed-doubles.cc",
-+ #"test-unboxed-doubles.cc",
- "test-unique.cc",
- "test-unscopables-hidden-prototype.cc",
- "test-usecounters.cc", \ No newline at end of file