summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2016-08-24 12:19:16 +0200
committerMarco Pompili2016-08-24 12:19:16 +0200
commit85992d5ec193948b7a5c152c2be499752e527588 (patch)
treef51b0a406f53debbd14111cfd486c46006e7715b
parent93e9d5b3a7c2e0f622415174b5660027a05b5574 (diff)
downloadaur-85992d5ec193948b7a5c152c2be499752e527588.tar.gz
Version 5.4.374.1-3, add shared libv8.so and i18n
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0165d57be170..4ceae4e9f186 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Aug 23 20:33:45 UTC 2016
+# Wed Aug 24 10:17:59 UTC 2016
pkgbase = v8
pkgdesc = Fast and modern Javascript engine used in Google Chrome.
pkgver = 5.4.374.1
- pkgrel = 2
+ pkgrel = 3
url = https://code.google.com/p/v8/
arch = i686
arch = x86_64
@@ -21,11 +21,9 @@ pkgbase = v8
conflicts = v8-3.15
conflicts = v8-3.20
source = depot_tools::git+https://chromium.googlesource.com/chromium/tools/depot_tools.git
- source = gyp::git+https://chromium.googlesource.com/external/gyp
source = v8.pc
source = d8
sha256sums = SKIP
- sha256sums = SKIP
sha256sums = 2b054309df9af9fb2e3e14527e88360b44745649b4866e592fb357ac90935f5d
sha256sums = cfd0712ee91d30b62e761da130e194c18f2b92a7f1654fb4af49f96ae9ce3e1b
diff --git a/PKGBUILD b/PKGBUILD
index c0e7b4f388fd..917e0fdb4500 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=v8
pkgver=5.4.374.1
-pkgrel=2
+pkgrel=3
pkgdesc="Fast and modern Javascript engine used in Google Chrome."
arch=('i686' 'x86_64')
url="https://code.google.com/p/v8/"
@@ -60,7 +60,9 @@ build() {
cd v8
msg2 "Running GN..."
- tools/dev/v8gen.py x64.release
+ tools/dev/v8gen.py x64.release -- \
+ is_component_build=true \
+ v8_enable_i18n_support=true
## Needs to resync after running GN
@@ -93,6 +95,8 @@ package() {
install -Dm755 out.gn/x64.release/d8 $pkgdir/usr/lib/v8/d8
install -Dm644 out.gn/x64.release/natives_blob.bin $pkgdir/usr/lib/v8/natives_blob.bin
install -Dm644 out.gn/x64.release/snapshot_blob.bin $pkgdir/usr/lib/v8/snapshot_blob.bin
+ install -Dm755 out.gn/x64.release/libv8.so $pkgdir/usr/lib/v8/libv8.so
+ ln -s v8/libv8.so $pkgdir/usr/lib/libv8.so
install -Dm755 $srcdir/d8 $pkgdir/usr/bin/d8
# V8 has several header files and ideally if it had its own folder in /usr/include