summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2015-12-02 02:22:10 +0100
committerMarco Pompili2015-12-02 02:22:10 +0100
commit942402f8e7d2ad5c4fc7f1bb618a36e8ee7f111e (patch)
tree250e2662beb0c641e2f4181b741cb1277725fda4
parent43ccd7166eb8071e54130e89b2bcda8fa43cd19e (diff)
downloadaur-942402f8e7d2ad5c4fc7f1bb618a36e8ee7f111e.tar.gz
Fixed segmentation fault (by hzy199411), 4.9.92-2
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD32
-rw-r--r--d82
3 files changed, 26 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f325e681c76..181594c9a09b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = v8
pkgdesc = Fast and modern Javascript engine used in Google Chrome.
pkgver = 4.9.92
- pkgrel = 1
+ pkgrel = 2
url = https://code.google.com/p/v8/
arch = i686
arch = x86_64
@@ -9,15 +9,18 @@ pkgbase = v8
makedepends = python2
makedepends = python2-virtualenv
makedepends = ninja
+ makedepends = git
depends = readline
depends = icu
depends = libtinfo
source = depot_tools::git+https://chromium.googlesource.com/chromium/tools/depot_tools.git
source = gyp::git+https://chromium.googlesource.com/external/gyp
source = v8.pc
+ source = d8
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 2b054309df9af9fb2e3e14527e88360b44745649b4866e592fb357ac90935f5d
+ sha256sums = 332760b620368475605e848e4b00b6c6fec4ea783891561c8f6b23aad2b02d8a
pkgname = v8
diff --git a/PKGBUILD b/PKGBUILD
index 112a98383eb0..b98048a05059 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,19 +6,21 @@
pkgname=v8
pkgver=4.9.92
-pkgrel=1
+pkgrel=2
pkgdesc="Fast and modern Javascript engine used in Google Chrome."
arch=("i686" "x86_64")
url="https://code.google.com/p/v8/"
license=("BSD")
depends=("readline" "icu" "libtinfo")
-makedepends=("python2" "python2-virtualenv" "ninja")
+makedepends=("python2" "python2-virtualenv" "ninja" "git")
source=("depot_tools::git+https://chromium.googlesource.com/chromium/tools/depot_tools.git"
"gyp::git+https://chromium.googlesource.com/external/gyp"
- "v8.pc")
+ "v8.pc"
+ "d8")
sha256sums=('SKIP'
'SKIP'
- '2b054309df9af9fb2e3e14527e88360b44745649b4866e592fb357ac90935f5d')
+ '2b054309df9af9fb2e3e14527e88360b44745649b4866e592fb357ac90935f5d'
+ '332760b620368475605e848e4b00b6c6fec4ea783891561c8f6b23aad2b02d8a')
case "$CARCH" in
x86_64) V8_ARCH="x64" ;;
@@ -73,17 +75,23 @@ check() {
package() {
cd v8
- install -Dm755 out/Release/d8 "$pkgdir"/usr/bin/d8
- install -Dm755 out/Release/lib/libv8.so "$pkgdir"/usr/lib/libv8.so
+ install -d $pkgdir/usr/lib/v8
+
+ install -Dm755 out/Release/d8 $pkgdir/usr/lib/v8/d8
+ install -Dm644 out/Release/natives_blob.bin $pkgdir/usr/lib/v8/natives_blob.bin
+ install -Dm755 out/Release/lib/libv8.so $pkgdir/usr/lib/v8/libv8.so
+ ln -s v8/libv8.so $pkgdir/usr/lib/libv8.so
+ install -Dm755 $srcdir/d8 $pkgdir/usr/bin/d8
+
# V8 has several header files and ideally if it had its own folder in /usr/include
# But doing it here will break all users. Ideally if they use provided pkgconfig file.
- install -d "$pkgdir"/usr/include
- install -Dm644 include/*.h "$pkgdir"/usr/include
+ install -d $pkgdir/usr/include
+ install -Dm644 include/*.h $pkgdir/usr/include
- install -d "$pkgdir"/usr/lib/pkgconfig
- install -m644 "$srcdir/v8.pc" "$pkgdir"/usr/lib/pkgconfig
+ install -d $pkgdir/usr/lib/pkgconfig
+ install -m644 $srcdir/v8.pc $pkgdir/usr/lib/pkgconfig
- install -d "$pkgdir"/usr/share/licenses/v8
- install -m644 LICENSE* "$pkgdir"/usr/share/licenses/v8
+ install -d $pkgdir/usr/share/licenses/v8
+ install -m644 LICENSE* $pkgdir/usr/share/licenses/v8
}
diff --git a/d8 b/d8
new file mode 100644
index 000000000000..e90c2d8bd6fa
--- /dev/null
+++ b/d8
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/lib/v8/d8