summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcs2018-05-28 16:17:58 +0200
committermarcs2018-05-28 16:17:58 +0200
commita887012c70de4fe224ad241ec26cd9aa89b108f1 (patch)
tree8e8d2aa5c69ca00727497ae777ab0cbad3da5bb4
parentd5970205eb20c8d106ee2baf4e926867d6c52809 (diff)
downloadaur-a887012c70de4fe224ad241ec26cd9aa89b108f1.tar.gz
Version 6.8.275.3-1
- Using python2 system installation instead of virtualenv. - Using bundled ICU instead of system ICU to avoid failing intl tests.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD53
-rw-r--r--ctest.patch26
3 files changed, 23 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abeec4ed575e..f0ce6d8b2b64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Dec 13 11:57:18 UTC 2017
+# Mon May 28 14:16:59 UTC 2018
pkgbase = v8
pkgdesc = Fast and modern Javascript engine used in Google Chrome.
- pkgver = 6.4.388.6
+ pkgver = 6.8.275.3
pkgrel = 1
url = https://code.google.com/p/v8/
arch = i686
@@ -11,7 +11,11 @@ pkgbase = v8
makedepends = clang
makedepends = clang-tools-extra
makedepends = python2
- makedepends = python2-virtualenv
+ makedepends = python2-colorama
+ makedepends = python2-pylint
+ makedepends = python2-lazy-object-proxy
+ makedepends = python2-singledispatch
+ makedepends = python2-wrapt
makedepends = ninja
makedepends = git
makedepends = wget
@@ -27,13 +31,11 @@ pkgbase = v8
source = v8_libbase.pc
source = v8_libplatform.pc
source = d8
- source = ctest.patch
sha256sums = SKIP
sha256sums = 3616bcfb15af7cd5a39bc0f223b2a52f15883a4bc8cfcfb291837c7421363d75
sha256sums = efb37bd706e6535abfa20c77bb16597253391619dae275627312d00ee7332fa3
sha256sums = ae23d543f655b4d8449f98828d0aff6858a777429b9ebdd2e23541f89645d4eb
sha256sums = 6abb07ab1cf593067d19028f385bd7ee52196fc644e315c388f08294d82ceff0
- sha256sums = db2f7e8b37d99a396b488d7657d6febb475371d42ec30fff8ffbb69983a9a09f
pkgname = v8
diff --git a/PKGBUILD b/PKGBUILD
index e0e0e9e6bb7e..312d2d3e00db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,28 +6,25 @@
# Contributor: David Flemström <david.flemstrom@gmail.com>
pkgname=v8
-pkgver=6.4.388.6
+pkgver=6.8.275.3
pkgrel=1
pkgdesc="Fast and modern Javascript engine used in Google Chrome."
arch=('i686' 'x86_64')
url="https://code.google.com/p/v8/"
license=('BSD')
depends=('readline' 'icu')
-makedepends=('clang' 'clang-tools-extra' 'python2' 'python2-virtualenv' 'ninja' 'git' 'wget')
+makedepends=('clang' 'clang-tools-extra' 'python2' 'python2-colorama' 'python2-pylint' 'python2-lazy-object-proxy' 'python2-singledispatch' 'python2-wrapt' 'ninja' 'git' 'wget')
conflicts=('v8-3.14' 'v8-3.15' 'v8-3.20' 'v8-static-gyp' 'v8-static-gyp-5.4')
source=("depot_tools::git+https://chromium.googlesource.com/chromium/tools/depot_tools.git"
"v8.pc"
"v8_libbase.pc"
"v8_libplatform.pc"
- "d8"
- "ctest.patch")
+ "d8")
sha256sums=('SKIP'
'3616bcfb15af7cd5a39bc0f223b2a52f15883a4bc8cfcfb291837c7421363d75'
'efb37bd706e6535abfa20c77bb16597253391619dae275627312d00ee7332fa3'
'ae23d543f655b4d8449f98828d0aff6858a777429b9ebdd2e23541f89645d4eb'
- '6abb07ab1cf593067d19028f385bd7ee52196fc644e315c388f08294d82ceff0'
- 'db2f7e8b37d99a396b488d7657d6febb475371d42ec30fff8ffbb69983a9a09f')
-
+ '6abb07ab1cf593067d19028f385bd7ee52196fc644e315c388f08294d82ceff0')
#
# Custom configuration for V8
@@ -81,18 +78,13 @@ esac
OUTFLD=out.gn/Release
prepare() {
- msg2 "Creating Python Virtual Environment"
- virtualenv2 -q venv
- msg2 "Activating Python Virtual Environment"
- source venv/bin/activate > /dev/null
- msg2 "Installing dependencies in the Virtual Environment..."
- pip install colorama -q
- pip install pylint -q
- pip install lazy-object-proxy -q
- pip install singledispatch -q
- pip install wrapt -q
-
- export PATH=`pwd`/depot_tools:"$PATH"
+ # Switching to python2 system environment
+ mkdir -p bin
+ ln -sf /usr/bin/python2 ./bin/python
+ ln -sf /usr/bin/python2-config ./bin/python-config
+ msg2 "Using: `which python`"
+
+ export PATH=${srcdir}/bin:`pwd`/depot_tools:"$PATH"
export GYP_GENERATORS=ninja
if [ ! -d "v8" ]; then
@@ -102,6 +94,9 @@ prepare() {
cd v8
+ msg2 "Reset repository"
+ git reset --hard
+
if [ -f third_party/icu/BUILD.gn.orig ]
then
msg2 "Restoring bundled ICU build files for syncing"
@@ -112,13 +107,7 @@ prepare() {
gclient sync --revision ${pkgver}
msg2 "Using system libraries for ICU"
- ./build/linux/unbundle/replace_gn_files.py --system-libraries icu
-
- #msg2 "Applying gcc7 compatibility patch"
- #patch -p1 -i ${srcdir}/gcc7.patch
-
- msg "Applying ctest patch"
- patch -p1 -i ${srcdir}/ctest.patch
+ ./build/linux/unbundle/replace_gn_files.py
sed "s/@VERSION@/${pkgver}/g" -i "${srcdir}/v8.pc"
sed "s/@VERSION@/${pkgver}/g" -i "${srcdir}/v8_libbase.pc"
@@ -136,13 +125,9 @@ prepare() {
v8_enable_i18n_support=$V8_I18N_SUPPORT
v8_use_external_startup_data=\"$V8_USE_EXTERNAL_STARTUP_DATA\"
use_sysroot=$V8_USE_SYSROOT"
-
- deactivate
}
build() {
- source venv/bin/activate > /dev/null
-
cd v8
# Fixes bug in generate_shim_headers.py that fails to create these dirs
@@ -152,23 +137,17 @@ build() {
msg2 "Building, this will take a while..."
ninja -C $OUTFLD
-
- deactivate
}
check() {
- source venv/bin/activate > /dev/null
-
cd v8
-
+ msg2 "Using `which python`"
msg2 "Testing, this will also take a while..."
tools/run-tests.py --no-presubmit \
--outdir=out.gn \
--buildbot \
--arch=$V8_ARCH \
--mode=Release
-
- deactivate
}
package() {
diff --git a/ctest.patch b/ctest.patch
deleted file mode 100644
index 1c6441a0d62b..000000000000
--- a/ctest.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/test/cctest/BUILD.gn b/test/cctest/BUILD.gn
-index ca81ef1f0d..0f90d99f60 100644
---- a/test/cctest/BUILD.gn
-+++ b/test/cctest/BUILD.gn
-@@ -205,7 +205,6 @@ v8_source_set("cctest_sources") {
- "test-typedarrays.cc",
- "test-types.cc",
- "test-unbound-queue.cc",
-- "test-unboxed-doubles.cc",
- "test-unscopables-hidden-prototype.cc",
- "test-usecounters.cc",
- "test-utils.cc",
-diff --git a/test/cctest/compiler/graph-builder-tester.h b/test/cctest/compiler/graph-builder-tester.h
-index 1bf1d40587..7a2559a126 100644
---- a/test/cctest/compiler/graph-builder-tester.h
-+++ b/test/cctest/compiler/graph-builder-tester.h
-@@ -168,9 +168,6 @@ class GraphBuilderTester : public HandleAndZoneScope,
- Node* ChangeUint32ToTagged(Node* a) {
- return NewNode(simplified()->ChangeUint32ToTagged(), a);
- }
-- Node* ChangeFloat64ToTagged(Node* a) {
-- return NewNode(simplified()->ChangeFloat64ToTagged(), a);
-- }
- Node* ChangeTaggedToBit(Node* a) {
- return NewNode(simplified()->ChangeTaggedToBit(), a);
- }