summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcs2017-12-02 18:14:24 +0100
committerMarcs2017-12-02 18:24:48 +0100
commitb244dac7823e0f1b63d6e4e8e9adb55968668878 (patch)
treefa562af42255dcb9deeae6ab988a047fcedcc995
parent6b78cc99e3cfc8160c913ba8ffdb90de0ca5ead7 (diff)
downloadaur-b244dac7823e0f1b63d6e4e8e9adb55968668878.tar.gz
Version 6.4.388.2-2, install libc++.so in /usr/lib/v8
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--gcc7.patch76
3 files changed, 7 insertions, 84 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c6277c28784..ef3627c0e18a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Dec 2 16:26:44 UTC 2017
+# Sat Dec 2 17:21:00 UTC 2017
pkgbase = v8
pkgdesc = Fast and modern Javascript engine used in Google Chrome.
pkgver = 6.4.388.2
- pkgrel = 1
+ pkgrel = 2
url = https://code.google.com/p/v8/
arch = i686
arch = x86_64
@@ -27,14 +27,12 @@ pkgbase = v8
source = v8_libbase.pc
source = v8_libplatform.pc
source = d8
- source = gcc7.patch
source = ctest.patch
sha256sums = SKIP
sha256sums = 3616bcfb15af7cd5a39bc0f223b2a52f15883a4bc8cfcfb291837c7421363d75
sha256sums = efb37bd706e6535abfa20c77bb16597253391619dae275627312d00ee7332fa3
sha256sums = ae23d543f655b4d8449f98828d0aff6858a777429b9ebdd2e23541f89645d4eb
sha256sums = 6abb07ab1cf593067d19028f385bd7ee52196fc644e315c388f08294d82ceff0
- sha256sums = 3a67793d1a7a93cec00f2693f11e79749364d2541edfb99d0be3f9c132382d1f
sha256sums = db2f7e8b37d99a396b488d7657d6febb475371d42ec30fff8ffbb69983a9a09f
pkgname = v8
diff --git a/PKGBUILD b/PKGBUILD
index 3c0bf1143d0f..b6d87754ed7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=v8
pkgver=6.4.388.2
-pkgrel=1
+pkgrel=2
pkgdesc="Fast and modern Javascript engine used in Google Chrome."
arch=('i686' 'x86_64')
url="https://code.google.com/p/v8/"
@@ -20,14 +20,12 @@ source=("depot_tools::git+https://chromium.googlesource.com/chromium/tools/depot
"v8_libbase.pc"
"v8_libplatform.pc"
"d8"
- "gcc7.patch"
"ctest.patch")
sha256sums=('SKIP'
'3616bcfb15af7cd5a39bc0f223b2a52f15883a4bc8cfcfb291837c7421363d75'
'efb37bd706e6535abfa20c77bb16597253391619dae275627312d00ee7332fa3'
'ae23d543f655b4d8449f98828d0aff6858a777429b9ebdd2e23541f89645d4eb'
'6abb07ab1cf593067d19028f385bd7ee52196fc644e315c388f08294d82ceff0'
- '3a67793d1a7a93cec00f2693f11e79749364d2541edfb99d0be3f9c132382d1f'
'db2f7e8b37d99a396b488d7657d6febb475371d42ec30fff8ffbb69983a9a09f')
@@ -178,11 +176,14 @@ package() {
install -d ${pkgdir}/usr/lib/v8
+ install -Dm755 $OUTFLD/cctest ${pkgdir}/usr/lib/v8/cctest
install -Dm755 $OUTFLD/d8 ${pkgdir}/usr/lib/v8/d8
- install -Dm755 $OUTFLD/libv8.so ${pkgdir}/usr/lib/libv8.so
+ install -Dm755 $OUTFLD/libc++.so ${pkgdir}/usr/lib/v8/libc++.so
+ install -Dm755 $OUTFLD/libv8_for_testing.so ${pkgdir}/usr/lib/libv8_for_testing.so
install -Dm755 $OUTFLD/libv8_libbase.so ${pkgdir}/usr/lib/libv8_libbase.so
install -Dm755 $OUTFLD/libv8_libplatform.so ${pkgdir}/usr/lib/libv8_libplatform.so
+ install -Dm755 $OUTFLD/libv8.so ${pkgdir}/usr/lib/libv8.so
install -Dm755 $OUTFLD/natives_blob.bin ${pkgdir}/usr/lib/v8/natives_blob.bin
install -Dm755 $OUTFLD/snapshot_blob.bin ${pkgdir}/usr/lib/v8/snapshot_blob.bin
diff --git a/gcc7.patch b/gcc7.patch
deleted file mode 100644
index bfaeb28ddfd1..000000000000
--- a/gcc7.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-diff --git a/src/objects-body-descriptors.h b/src/objects-body-descriptors.h
-index 499c48a930..3eb3bb539e 100644
---- a/src/objects-body-descriptors.h
-+++ b/src/objects-body-descriptors.h
-@@ -99,7 +99,7 @@ class FixedBodyDescriptor final : public BodyDescriptorBase {
-
- template <typename StaticVisitor>
- static inline void IterateBody(HeapObject* obj, int object_size) {
-- IterateBody(obj);
-+ IterateBody<StaticVisitor>(obj);
- }
-
- static inline int SizeOf(Map* map, HeapObject* object) { return kSize; }
-diff --git a/src/objects-inl.h b/src/objects-inl.h
-index 406f49d996..a2e7a6d1fc 100644
---- a/src/objects-inl.h
-+++ b/src/objects-inl.h
-@@ -47,6 +47,27 @@
- namespace v8 {
- namespace internal {
-
-+template <typename Derived, typename Shape, typename Key>
-+uint32_t HashTable<Derived, Shape, Key>::Hash(Key key) {
-+ if (Shape::UsesSeed) {
-+ return Shape::SeededHash(key, GetHeap()->HashSeed());
-+ } else {
-+ return Shape::Hash(key);
-+ }
-+}
-+
-+
-+template <typename Derived, typename Shape, typename Key>
-+uint32_t HashTable<Derived, Shape, Key>::HashForObject(Key key,
-+ Object* object) {
-+ if (Shape::UsesSeed) {
-+ return Shape::SeededHashForObject(key, GetHeap()->HashSeed(), object);
-+ } else {
-+ return Shape::HashForObject(key, object);
-+ }
-+}
-+
-+
- PropertyDetails::PropertyDetails(Smi* smi) {
- value_ = smi->value();
- }
-diff --git a/src/objects/hash-table.h b/src/objects/hash-table.h
-index f3c68a82c5..71ce2a5613 100644
---- a/src/objects/hash-table.h
-+++ b/src/objects/hash-table.h
-@@ -138,22 +138,10 @@ class HashTable : public HashTableBase {
- public:
- typedef Shape ShapeT;
-
-- // Wrapper methods
-- inline uint32_t Hash(Key key) {
-- if (Shape::UsesSeed) {
-- return Shape::SeededHash(key, GetHeap()->HashSeed());
-- } else {
-- return Shape::Hash(key);
-- }
-- }
--
-- inline uint32_t HashForObject(Key key, Object* object) {
-- if (Shape::UsesSeed) {
-- return Shape::SeededHashForObject(key, GetHeap()->HashSeed(), object);
-- } else {
-- return Shape::HashForObject(key, object);
-- }
-- }
-+ // Wrapper methods. Defined in src/objects-inl.h
-+ // to break a cycle with src/heap/heap.h.
-+ inline uint32_t Hash(Key key);
-+ inline uint32_t HashForObject(Key key, Object* object);
-
- // Returns a new HashTable object.
- MUST_USE_RESULT static Handle<Derived> New(