summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranklyn Tackitt2017-02-07 11:15:54 -0700
committerFranklyn Tackitt2017-02-07 11:15:54 -0700
commit37831c86c078bc22bb17a9ccccb1e1bbefe8ec29 (patch)
tree3081dbe0966df61433d08c5bc732a733ad2e54e6
downloadaur-37831c86c078bc22bb17a9ccccb1e1bbefe8ec29.tar.gz
Initial build
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD32
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6522e705f1a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Tue Feb 7 18:15:32 UTC 2017
+pkgbase = v8-3.14-bin
+ pkgdesc = v8 3.14 binary package from ubuntu xenial
+ pkgver = 3.14.5.8
+ pkgrel = 1
+ url = https://github.com/v8/v8
+ arch = i686
+ arch = x86_64
+ license = BSD new
+ makedepends = git
+ provides = v8-3.14
+ conflicts = v8-3.14
+ source_i686 = http://mirrors.kernel.org/ubuntu/pool/universe/libv/libv8-3.14/libv8-3.14.5_3.14.5.8-5ubuntu2_i386.deb
+ md5sums_i686 = e773e65367409dc2a737443e2dbfe954
+ source_x86_64 = http://mirrors.kernel.org/ubuntu/pool/universe/libv/libv8-3.14/libv8-3.14.5_3.14.5.8-5ubuntu2_amd64.deb
+ md5sums_x86_64 = 3937ddaf045f8c5606b6c505bf0779f8
+
+pkgname = v8-3.14-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..deddb6ca8783
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.deb
+*.tar
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19acbe3a9328
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Franklyn Tackitt <franklyn@tackitt.net>
+
+pkgname=v8-3.14-bin
+pkgver=3.14.5.8
+pkgrel=1
+pkgdesc="v8 3.14 binary package from ubuntu xenial"
+url="https://github.com/v8/v8"
+arch=('i686' 'x86_64')
+license=('BSD new')
+depends=()
+makedepends=('git')
+conflicts=('v8-3.14')
+provides=('v8-3.14')
+
+source_i686=("http://mirrors.kernel.org/ubuntu/pool/universe/libv/libv8-3.14/libv8-3.14.5_${pkgver}-5ubuntu2_i386.deb")
+source_x86_64=("http://mirrors.kernel.org/ubuntu/pool/universe/libv/libv8-3.14/libv8-3.14.5_${pkgver}-5ubuntu2_amd64.deb")
+md5sums_i686=('e773e65367409dc2a737443e2dbfe954')
+md5sums_x86_64=('3937ddaf045f8c5606b6c505bf0779f8')
+
+package() {
+ msg2 "Unpacking data.tar.xz (Ubuntu package files)"
+ tar -xf data.tar.xz
+
+ install -Dm644 ${srcdir}/usr/lib/libv8.so.3.14.5 ${pkgdir}/usr/lib/libv8.so.3.14.5
+ install -Dm644 ${srcdir}/usr/share/doc/libv8-3.14.5/AUTHORS ${pkgdir}/usr/share/doc/libv8-3.14.5/AUTHORS
+ install -Dm644 ${srcdir}/usr/share/doc/libv8-3.14.5/copyright ${pkgdir}/usr/share/doc/libv8-3.14.5/copyright
+
+ msg2 "Fixing permissions differences between Ubuntu and Arch"
+ find ${pkgdir} -type d -exec chmod -cR 755 "{}" \;
+ find ${pkgdir}/usr/{lib,share} -type f -exec chmod -cR 644 "{}" \;
+}
+