summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranklyn Tackitt2019-02-27 08:43:12 -0700
committerFranklyn Tackitt2019-02-27 08:43:12 -0700
commit3ff0b5f78e8f009ffd0f5a9399d76b3b3b2fa3cb (patch)
tree0678a1fbd386e881b18aaed159370d2f3e94dd1d
parent37831c86c078bc22bb17a9ccccb1e1bbefe8ec29 (diff)
downloadaur-3ff0b5f78e8f009ffd0f5a9399d76b3b3b2fa3cb.tar.gz
Add -dev package to add headers
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 29 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6522e705f1a6..4fdf2a19138b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
-# Generated by mksrcinfo v8
-# Tue Feb 7 18:15:32 UTC 2017
pkgbase = v8-3.14-bin
pkgdesc = v8 3.14 binary package from ubuntu xenial
pkgver = 3.14.5.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/v8/v8
- arch = i686
arch = x86_64
license = BSD new
- makedepends = git
provides = v8-3.14
conflicts = v8-3.14
- source_i686 = http://mirrors.kernel.org/ubuntu/pool/universe/libv/libv8-3.14/libv8-3.14.5_3.14.5.8-5ubuntu2_i386.deb
- md5sums_i686 = e773e65367409dc2a737443e2dbfe954
- source_x86_64 = http://mirrors.kernel.org/ubuntu/pool/universe/libv/libv8-3.14/libv8-3.14.5_3.14.5.8-5ubuntu2_amd64.deb
- md5sums_x86_64 = 3937ddaf045f8c5606b6c505bf0779f8
+ noextract = libv8-3.14.5_3.14.5.8-5ubuntu2_amd64.deb
+ noextract = libv8-dev_3.14.5.8-5ubuntu2_amd64.deb
+ source = https://mirrors.kernel.org/ubuntu/pool/universe/libv/libv8-3.14/libv8-3.14.5_3.14.5.8-5ubuntu2_amd64.deb
+ source = https://mirrors.kernel.org/ubuntu/pool/universe/libv/libv8-3.14/libv8-dev_3.14.5.8-5ubuntu2_amd64.deb
+ sha512sums = 18a0ca972b8a3b8ba1171bf763876d2ef2b1577496457b04dfec78efb84992093181a42576cf5ab1c84cabe446ad9726f0713a5355779c865351ecc12b6f2b5b
+ sha512sums = e8c2a179b7400a82da762dbe4f166de1dfc2da84afbbf35cd110739852a97ec62558e49f23868854ea85981d54553754ed37b00d50cf702bdd6a29cf5333545c
pkgname = v8-3.14-bin
diff --git a/PKGBUILD b/PKGBUILD
index 19acbe3a9328..e5be7fe695aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,37 @@
pkgname=v8-3.14-bin
pkgver=3.14.5.8
-pkgrel=1
+pkgrel=2
pkgdesc="v8 3.14 binary package from ubuntu xenial"
url="https://github.com/v8/v8"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('BSD new')
depends=()
-makedepends=('git')
+makedepends=()
conflicts=('v8-3.14')
provides=('v8-3.14')
-source_i686=("http://mirrors.kernel.org/ubuntu/pool/universe/libv/libv8-3.14/libv8-3.14.5_${pkgver}-5ubuntu2_i386.deb")
-source_x86_64=("http://mirrors.kernel.org/ubuntu/pool/universe/libv/libv8-3.14/libv8-3.14.5_${pkgver}-5ubuntu2_amd64.deb")
-md5sums_i686=('e773e65367409dc2a737443e2dbfe954')
-md5sums_x86_64=('3937ddaf045f8c5606b6c505bf0779f8')
+source=("https://mirrors.kernel.org/ubuntu/pool/universe/libv/libv8-3.14/libv8-3.14.5_${pkgver}-5ubuntu2_amd64.deb"
+ "https://mirrors.kernel.org/ubuntu/pool/universe/libv/libv8-3.14/libv8-dev_${pkgver}-5ubuntu2_amd64.deb")
+noextract=("libv8-3.14.5_${pkgver}-5ubuntu2_amd64.deb" "libv8-dev_${pkgver}-5ubuntu2_amd64.deb")
+sha512sums=('18a0ca972b8a3b8ba1171bf763876d2ef2b1577496457b04dfec78efb84992093181a42576cf5ab1c84cabe446ad9726f0713a5355779c865351ecc12b6f2b5b'
+ 'e8c2a179b7400a82da762dbe4f166de1dfc2da84afbbf35cd110739852a97ec62558e49f23868854ea85981d54553754ed37b00d50cf702bdd6a29cf5333545c')
+
+prepare() {
+ msg2 "Unpacking libv8-3.14.5_${pkgver}-5ubuntu2_amd64.deb"
+ ar p "libv8-3.14.5_${pkgver}-5ubuntu2_amd64.deb" data.tar.xz | tar Jx
+
+ msg2 "Unpacking libv8-dev_${pkgver}-5ubuntu2_amd64.deb"
+ ar p "libv8-dev_${pkgver}-5ubuntu2_amd64.deb" data.tar.xz | tar Jx
+}
package() {
- msg2 "Unpacking data.tar.xz (Ubuntu package files)"
- tar -xf data.tar.xz
-
- install -Dm644 ${srcdir}/usr/lib/libv8.so.3.14.5 ${pkgdir}/usr/lib/libv8.so.3.14.5
- install -Dm644 ${srcdir}/usr/share/doc/libv8-3.14.5/AUTHORS ${pkgdir}/usr/share/doc/libv8-3.14.5/AUTHORS
- install -Dm644 ${srcdir}/usr/share/doc/libv8-3.14.5/copyright ${pkgdir}/usr/share/doc/libv8-3.14.5/copyright
+ install -Dm644 ${srcdir}/usr/lib/libv8.so.3.14.5 ${pkgdir}/usr/lib/libv8.so.3.14.5
+ install -Dm644 ${srcdir}/usr/share/doc/libv8-3.14.5/copyright ${pkgdir}/usr/share/doc/libv8-3.14.5/LICENSE
+ install -Dm644 ${srcdir}/usr/share/doc/libv8-dev/copyright ${pkgdir}/usr/share/doc/libv8-3.14.5-dev/LICENSE
- msg2 "Fixing permissions differences between Ubuntu and Arch"
- find ${pkgdir} -type d -exec chmod -cR 755 "{}" \;
- find ${pkgdir}/usr/{lib,share} -type f -exec chmod -cR 644 "{}" \;
+ for file in ${srcdir}/usr/share/doc/libv8-dev/examples/* ${srcdir}/usr/include/*; do
+ install -Dm644 "$file" "${file/$srcdir/$pkgdir}"
+ done
}