summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-03-02 19:45:55 +0100
committerPhilipp A2019-03-02 19:45:55 +0100
commitd51146126aa64a2f92d02ad2982f03ef9ecc5ea2 (patch)
tree487a3daedd621e43fa081e7e17e73bdfe79c8433
parent3ff0b5f78e8f009ffd0f5a9399d76b3b3b2fa3cb (diff)
downloadaur-d51146126aa64a2f92d02ad2982f03ef9ecc5ea2.tar.gz
install LICENSE and lib correctly
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fdf2a19138b..7bc613806401 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = v8-3.14-bin
pkgdesc = v8 3.14 binary package from ubuntu xenial
pkgver = 3.14.5.8
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/v8/v8
arch = x86_64
- license = BSD new
+ license = BSD
provides = v8-3.14
conflicts = v8-3.14
noextract = libv8-3.14.5_3.14.5.8-5ubuntu2_amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index e5be7fe695aa..059852ba0619 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
pkgname=v8-3.14-bin
pkgver=3.14.5.8
-pkgrel=2
-pkgdesc="v8 3.14 binary package from ubuntu xenial"
-url="https://github.com/v8/v8"
+pkgrel=3
+pkgdesc='v8 3.14 binary package from ubuntu xenial'
+url='https://github.com/v8/v8'
arch=('x86_64')
-license=('BSD new')
+license=('BSD')
depends=()
makedepends=()
conflicts=('v8-3.14')
@@ -27,12 +27,11 @@ prepare() {
}
package() {
- install -Dm644 ${srcdir}/usr/lib/libv8.so.3.14.5 ${pkgdir}/usr/lib/libv8.so.3.14.5
- install -Dm644 ${srcdir}/usr/share/doc/libv8-3.14.5/copyright ${pkgdir}/usr/share/doc/libv8-3.14.5/LICENSE
- install -Dm644 ${srcdir}/usr/share/doc/libv8-dev/copyright ${pkgdir}/usr/share/doc/libv8-3.14.5-dev/LICENSE
+ install -Dm755 "${srcdir}/usr/lib/libv8.so.3.14.5" -t "${pkgdir}/usr/lib/"
+ install -Dm644 "${srcdir}/usr/share/doc/libv8-dev/copyright" "${pkgdir}/usr/share/licenses/v8-3.14/LICENSE"
- for file in ${srcdir}/usr/share/doc/libv8-dev/examples/* ${srcdir}/usr/include/*; do
- install -Dm644 "$file" "${file/$srcdir/$pkgdir}"
+ for file in "${srcdir}/usr/share/doc/libv8-dev/examples/"* "${srcdir}/usr/include/"*; do
+ install -Dm644 "$file" "${file/$srcdir/$pkgdir}"
done
}