summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Marvin Garbuszus2020-01-11 09:20:58 +0100
committerJan Marvin Garbuszus2020-01-11 09:20:58 +0100
commit85e570705479c1e99b15fc9cfb7e892f9e717bfb (patch)
treeda09e64638dc977173310f21b785d5e4c8a0fdf0
parentf8bd5cdef270e8669b34b115e1e575fbcd987460 (diff)
downloadaur-85e570705479c1e99b15fc9cfb7e892f9e717bfb.tar.gz
update to 8.1.145 requires V8 3.0
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6365f16ab195..0249512f727d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Contributor: David Flemström <david.flemstrom@gmail.com>
pkgname=v8-r
-pkgver=7.9.81
+pkgver=8.1.145
pkgrel=1
pkgdesc="Fast and modern Javascript engine used in Google Chrome."
arch=('x86_64')
@@ -43,6 +43,7 @@ prepare() {
msg2 "Using: `which python`"
export PATH=${srcdir}/bin:`pwd`/depot_tools:"$PATH"
+ # export PATH=${srcdir}/depot_tools:"$PATH"
export GYP_GENERATORS=ninja
if [ ! -d "v8" ]; then
@@ -108,7 +109,6 @@ check() {
msg2 "Testing, this will also take a while..."
tools/run-tests.py --no-presubmit \
--outdir=out.gn \
- --buildbot \
--arch="x64" \
--mode=Release || true
}
@@ -125,6 +125,7 @@ package() {
install -Dm755 $OUTFLD/libv8_libbase.so ${pkgdir}/usr/lib/libv8_libbase.so
install -Dm755 $OUTFLD/libv8_libplatform.so ${pkgdir}/usr/lib/libv8_libplatform.so
install -Dm755 $OUTFLD/libv8.so ${pkgdir}/usr/lib/libv8.so
+ install -Dm755 $OUTFLD/libchrome_zlib.so ${pkgdir}/usr/lib/libchrome_zlib.so
install -Dm755 ${srcdir}/d8 ${pkgdir}/usr/bin/d8