summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Marvin Garbuszus2020-02-14 17:55:21 +0100
committerJan Marvin Garbuszus2020-02-14 17:55:21 +0100
commita8431182760309e062e3ad2e7a44ea4924b0633e (patch)
tree91b2faeddbb9a9571e854f900f271edb4b3e94a0
parent6b31521cb323222ab49d7ec22825c1ab4ba01784 (diff)
downloadaur-a8431182760309e062e3ad2e7a44ea4924b0633e.tar.gz
8.2.78
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--revert.diff21
3 files changed, 33 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f6c5d1df473..8cfa6cfb099c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = v8-r
pkgdesc = Google's open source JavaScript and WebAssembly engine
- pkgver = 8.2.37
+ pkgver = 8.2.78
pkgrel = 1
url = https://v8.dev
arch = x86_64
@@ -25,11 +25,13 @@ pkgbase = v8-r
source = v8_libbase.pc
source = v8_libplatform.pc
source = d8
+ source = revert.diff
sha256sums = SKIP
sha256sums = 3616bcfb15af7cd5a39bc0f223b2a52f15883a4bc8cfcfb291837c7421363d75
sha256sums = efb37bd706e6535abfa20c77bb16597253391619dae275627312d00ee7332fa3
sha256sums = ae23d543f655b4d8449f98828d0aff6858a777429b9ebdd2e23541f89645d4eb
sha256sums = 6abb07ab1cf593067d19028f385bd7ee52196fc644e315c388f08294d82ceff0
+ sha256sums = 9e3fcb8191efbf2483278e054a355f55d21feadaa69b855921643c429869302c
pkgname = v8-r
diff --git a/PKGBUILD b/PKGBUILD
index d6554f8b7dc6..1c840cecec9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Contributor: David Flemström <david.flemstrom@gmail.com>
pkgname=v8-r
-pkgver=8.2.37
+pkgver=8.2.78
pkgrel=1
pkgdesc="Google's open source JavaScript and WebAssembly engine"
arch=('x86_64')
@@ -22,12 +22,14 @@ source=("depot_tools::git+https://chromium.googlesource.com/chromium/tools/depot
"v8.pc"
"v8_libbase.pc"
"v8_libplatform.pc"
- "d8")
+ "d8"
+ "revert.diff")
sha256sums=('SKIP'
'3616bcfb15af7cd5a39bc0f223b2a52f15883a4bc8cfcfb291837c7421363d75'
'efb37bd706e6535abfa20c77bb16597253391619dae275627312d00ee7332fa3'
'ae23d543f655b4d8449f98828d0aff6858a777429b9ebdd2e23541f89645d4eb'
- '6abb07ab1cf593067d19028f385bd7ee52196fc644e315c388f08294d82ceff0')
+ '6abb07ab1cf593067d19028f385bd7ee52196fc644e315c388f08294d82ceff0'
+ '9e3fcb8191efbf2483278e054a355f55d21feadaa69b855921643c429869302c')
OUTFLD=out.gn/Release
@@ -69,6 +71,9 @@ prepare() {
msg2 "Using system libraries for ICU"
$srcdir/v8/build/linux/unbundle/replace_gn_files.py --system-libraries icu
+ # fix build: comment -fintegrated-cc1
+ patch -p2 < ../revert.diff
+
sed "s/@VERSION@/${pkgver}/g" -i "${srcdir}/v8.pc"
sed "s/@VERSION@/${pkgver}/g" -i "${srcdir}/v8_libbase.pc"
sed "s/@VERSION@/${pkgver}/g" -i "${srcdir}/v8_libplatform.pc"
@@ -89,6 +94,7 @@ prepare() {
use_custom_libcxx=false
linux_use_bundled_binutils=false
use_sysroot=false'
+
}
build() {
diff --git a/revert.diff b/revert.diff
new file mode 100644
index 000000000000..b367c36d4475
--- /dev/null
+++ b/revert.diff
@@ -0,0 +1,21 @@
+diff --git a/config/compiler/BUILD.gn b/config/compiler/BUILD.gn
+index fb06b9556..0180e201e 100644
+--- a/v8/build/config/compiler/BUILD.gn
++++ b/v8/build/config/compiler/BUILD.gn
+@@ -499,11 +499,11 @@ config("compiler") {
+ "-instcombine-lower-dbg-declare=0",
+ ]
+
+- if (target_os != "chromeos") {
+- # TODO(https://crbug.com/1049161): Remove '-DCLANG_SPAWN_CC1=ON' from build.py instead
+- # once this change has marinated a bit.
+- cflags += [ "-fintegrated-cc1" ]
+- }
++ # if (target_os != "chromeos") {
++ # # TODO(https://crbug.com/1049161): Remove '-DCLANG_SPAWN_CC1=ON' from build.py instead
++ # # once this change has marinated a bit.
++ # cflags += [ "-fintegrated-cc1" ]
++ # }
+ }
+
+ # C11/C++11 compiler flags setup.