summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Ryan2015-06-08 21:47:13 +1200
committerJason Ryan2015-06-08 21:47:13 +1200
commit8823a32b688997704b32378077756fcc69ffd654 (patch)
tree795884e49a86413baadac4caf8de763880abaa39
downloadaur-8823a32b688997704b32378077756fcc69ffd654.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
-rw-r--r--modprobe.uvesafb10
-rw-r--r--v86d_hook4
-rw-r--r--v86d_install14
5 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1e9545e985d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = v86d
+ pkgdesc = userspace helper for uvesafb that runs x86 code in an emulated environment
+ pkgver = 0.1.10
+ pkgrel = 5
+ url = https://github.com/mjanusz/v86d
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = glibc
+ options = !makeflags
+ source = git://github.com/mjanusz/v86d.git#tag=v86d-0.1.10
+ source = v86d_install
+ source = v86d_hook
+ source = modprobe.uvesafb
+ md5sums = SKIP
+ md5sums = 66ab32602ab29cc5635eaac7f3e42283
+ md5sums = 5f75b8bc4a7ddf595014591e5db263cb
+ md5sums = 2d7cc8dc6a41916a13869212d0191147
+
+pkgname = v86d
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6fb8c4664bf0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: jason ryan <jasonwryan@gmail.com>
+
+pkgname=v86d
+pkgver=0.1.10
+pkgrel=5
+pkgdesc="userspace helper for uvesafb that runs x86 code in an emulated environment"
+arch=('i686' 'x86_64')
+url="https://github.com/mjanusz/v86d"
+license=('GPL2')
+depends=('glibc')
+makedepends=('git')
+options=('!makeflags')
+source=("git://github.com/mjanusz/v86d.git#tag=$pkgname-$pkgver"
+ v86d_install
+ v86d_hook
+ modprobe.uvesafb)
+md5sums=(SKIP
+ '66ab32602ab29cc5635eaac7f3e42283'
+ '5f75b8bc4a7ddf595014591e5db263cb'
+ '2d7cc8dc6a41916a13869212d0191147')
+
+build() {
+ cd "$pkgname"
+ ./configure --with-x86emu
+ # we only need /usr/include/video/uvesafb.h
+ make KDIR=/usr
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" install
+
+ install -D -m644 "$srcdir/v86d_install" "$pkgdir/usr/lib/initcpio/install/v86d"
+ install -D -m644 "$srcdir/v86d_hook" "$pkgdir/usr/lib/initcpio/hooks/v86d"
+ install -D -m644 "$srcdir/modprobe.uvesafb" "$pkgdir/usr/lib/modprobe.d/uvesafb.conf"
+
+ # usrmove
+ cd "$pkgdir"
+ mv sbin usr/bin
+}
diff --git a/modprobe.uvesafb b/modprobe.uvesafb
new file mode 100644
index 000000000000..5e46e108833a
--- /dev/null
+++ b/modprobe.uvesafb
@@ -0,0 +1,10 @@
+#
+# This file sets the parameters for uvesafb module.
+# The following format should be used:
+# options uvesafb mode=<xres>x<yres>[-<bpp>][@<refresh>] scroll=<ywrap|ypan|redraw> ...
+#
+# For more details see:
+# http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blob;f=Documentation/fb/uvesafb.txt
+#
+
+options uvesafb mode_option=1024x768-32 scroll=ywrap
diff --git a/v86d_hook b/v86d_hook
new file mode 100644
index 000000000000..2b4375e15c71
--- /dev/null
+++ b/v86d_hook
@@ -0,0 +1,4 @@
+run_hook()
+{
+ /sbin/modprobe uvesafb
+}
diff --git a/v86d_install b/v86d_install
new file mode 100644
index 000000000000..840b34eec3c1
--- /dev/null
+++ b/v86d_install
@@ -0,0 +1,14 @@
+build() {
+ add_module 'uvesafb'
+
+ add_binary "v86d"
+ add_file "/usr/lib/modprobe.d/uvesafb.conf"
+
+ add_runscript
+}
+
+help() {
+ echo "This hook sets up v86d, the userspace helper for uvesafb."
+}
+
+# vim: set ft=sh ts=4 sw=4 expandtab: