summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordreieck2022-05-10 12:53:31 +0200
committerdreieck2022-05-10 12:53:31 +0200
commitc72b8b2388352dde20ee3515849b6bc49d1be7ef (patch)
treeed7ebd353f4d2d4a8d9712c5a0ed3014192131b7
parent6a8b4961e7006d0c2114c2541245b4a838454868 (diff)
downloadaur-c72b8b2388352dde20ee3515849b6bc49d1be7ef.tar.gz
Adopted, and cleanup.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD49
-rw-r--r--initcpio_uvesafb_hook (renamed from v86d_hook)0
-rw-r--r--initcpio_uvesafb_install (renamed from v86d_install)0
-rw-r--r--modprobe_uvesafb.conf (renamed from modprobe.uvesafb)0
5 files changed, 39 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbf28bab6b02..ef5c5fd5d41b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = v86d
- pkgdesc = userspace helper for uvesafb that runs x86 code in an emulated environment
+ pkgdesc = userspace helper for uvesafb that runs x86 code in an emulated environment.
pkgver = 0.1.10
- pkgrel = 9
+ pkgrel = 10
url = https://github.com/mjanusz/v86d
arch = i686
arch = x86_64
@@ -9,14 +9,13 @@ pkgbase = v86d
makedepends = git
depends = glibc
options = !makeflags
- source = git://github.com/mjanusz/v86d.git#tag=v86d-0.1.10
- source = v86d_install
- source = v86d_hook
- source = modprobe.uvesafb
- md5sums = SKIP
- md5sums = 66ab32602ab29cc5635eaac7f3e42283
- md5sums = 5f75b8bc4a7ddf595014591e5db263cb
- md5sums = 2d7cc8dc6a41916a13869212d0191147
+ source = v86d::git+https://github.com/mjanusz/v86d.git#tag=v86d-0.1.10
+ source = initcpio_uvesafb_install
+ source = initcpio_uvesafb_hook
+ source = modprobe_uvesafb.conf
+ sha256sums = SKIP
+ sha256sums = b33de32a20303dbae9a4ef20636852170d740afb832249903ff37e7454311663
+ sha256sums = e1c05aabfb25d40de51555865286b22a5511ff1dc85cb7af0ab1baa896e32dd5
+ sha256sums = 5d5949ec23a546d1468327e5496e8cc2b0b2015b84ff8bedb6d0b462df59bd19
pkgname = v86d
-
diff --git a/PKGBUILD b/PKGBUILD
index 1244480f40b7..6b4c1246aa47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,50 @@
-# Maintainer: jason ryan <jasonwryan@gmail.com>
+# Maintainer: dreieck
+# Contributor: jason ryan <jasonwryan@gmail.com>
# Submaintainer : bartus <arch-user-repoᘓbartus.33mail.com>
-pkgname=v86d
+_pkgname=v86d
+pkgname="${_pkgname}"
pkgver=0.1.10
-pkgrel=9
-pkgdesc="userspace helper for uvesafb that runs x86 code in an emulated environment"
+pkgrel=10
+pkgdesc="userspace helper for uvesafb that runs x86 code in an emulated environment."
arch=('i686' 'x86_64')
url="https://github.com/mjanusz/v86d"
license=('GPL2')
depends=('glibc')
makedepends=('git')
options=('!makeflags')
-source=("git://github.com/mjanusz/v86d.git#tag=$pkgname-$pkgver"
- v86d_install
- v86d_hook
- modprobe.uvesafb)
-md5sums=('SKIP'
- '66ab32602ab29cc5635eaac7f3e42283'
- '5f75b8bc4a7ddf595014591e5db263cb'
- '2d7cc8dc6a41916a13869212d0191147')
+source=(
+ "${_pkgname}::git+https://github.com/mjanusz/v86d.git#tag=${pkgname}-${pkgver}"
+ initcpio_uvesafb_install
+ initcpio_uvesafb_hook
+ modprobe_uvesafb.conf
+)
+sha256sums=(
+ 'SKIP'
+ 'b33de32a20303dbae9a4ef20636852170d740afb832249903ff37e7454311663'
+ 'e1c05aabfb25d40de51555865286b22a5511ff1dc85cb7af0ab1baa896e32dd5'
+ '5d5949ec23a546d1468327e5496e8cc2b0b2015b84ff8bedb6d0b462df59bd19'
+)
build() {
- cd "$pkgname"
+ cd "${srcdir}/${_pkgname}"
./configure --with-x86emu
# we only need /usr/include/video/uvesafb.h
make KDIR=/usr
}
package() {
- cd "$pkgname"
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/${_pkgname}"
- install -D -m644 "$srcdir/v86d_install" "$pkgdir/usr/lib/initcpio/install/v86d"
- install -D -m644 "$srcdir/v86d_hook" "$pkgdir/usr/lib/initcpio/hooks/v86d"
- install -D -m644 "$srcdir/modprobe.uvesafb" "$pkgdir/usr/lib/modprobe.d/uvesafb.conf"
+ make DESTDIR="${pkgdir}" install
+
+ install -D -v -m644 "${srcdir}/initcpio_uvesafb_install" "${pkgdir}/usr/share/doc/${_pkgname}/examples/etc/initcpio/install/uvesafb"
+ install -D -v -m644 "${srcdir}/initcpio_uvesafb_hook" "${pkgdir}/usr/share/doc/${_pkgname}/examples/etc/initcpio/hooks/uvesafb"
+ install -D -v -m644 "${srcdir}/modprobe_uvesafb.conf" "${pkgdir}/usr/share/doc/${_pkgname}/examples/etc/modprobe.d/uvesafb.conf"
+ install -D -v -m644 "${srcdir}/${_pkgname}/README" "${pkgdir}/usr/share/doc/${_pkgname}/README"
+ install -D -v -m644 "${srcdir}/${_pkgname}/TODO" "${pkgdir}/usr/share/doc/${_pkgname}/TODO"
# usrmove
- cd "$pkgdir"
- mv sbin usr/bin
+ cd "${pkgdir}"
+ mv -v sbin usr/bin
}
diff --git a/v86d_hook b/initcpio_uvesafb_hook
index 2b4375e15c71..2b4375e15c71 100644
--- a/v86d_hook
+++ b/initcpio_uvesafb_hook
diff --git a/v86d_install b/initcpio_uvesafb_install
index 840b34eec3c1..840b34eec3c1 100644
--- a/v86d_install
+++ b/initcpio_uvesafb_install
diff --git a/modprobe.uvesafb b/modprobe_uvesafb.conf
index 5e46e108833a..5e46e108833a 100644
--- a/modprobe.uvesafb
+++ b/modprobe_uvesafb.conf