summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordplusplus2022-03-03 02:15:26 -0800
committerdplusplus2022-03-03 02:15:26 -0800
commit9184409f4fe272200ddbd606daf7ae672b6af3fc (patch)
tree5aac13bedb0c8982da3783f191c17de26778096d
downloadaur-9184409f4fe272200ddbd606daf7ae672b6af3fc.tar.gz
Working PKGBUILD and other files for VA-11 Hall-A (GOG version)
-rw-r--r--.SRCINFO29
-rw-r--r--0000-start.sh.patch21
-rw-r--r--PKGBUILD74
-rw-r--r--va-11-hall-a-gog26
-rw-r--r--va-11-hall-a-gog.desktop7
-rw-r--r--va-11-hall-a-gog.profile42
6 files changed, 199 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b0ef49d4675
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = va-11-hall-a-gog
+ pkgdesc = Bartender simulator visual novel game
+ pkgver = 1.2.3.0
+ pkgrel = 1
+ url = https://waifubartending.com
+ arch = i686
+ arch = x86_64
+ groups = games
+ groups = gog
+ license = custom
+ makedepends = p7zip
+ depends = lib32-glu
+ depends = lib32-libxrandr
+ depends = lib32-openal
+ depends = lib32-openssl-1.0
+ optdepends = firejail: sandboxing
+ options = !strip
+ source = gog://va_11_hall_a_cyberpunk_bartender_action_en_1_2_3_0_18496.sh
+ source = va-11-hall-a-gog
+ source = va-11-hall-a-gog.desktop
+ source = va-11-hall-a-gog.profile
+ source = 0000-start.sh.patch
+ sha512sums = 1f5a10cc3b543b355adff3c09ae5e44f5050b20d3bfb9e704cfe06f2e894045d743ccf3e94aef5f7dd4b444e9cf18abc7800718f04280c83c441e46d664902da
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = va-11-hall-a-gog
diff --git a/0000-start.sh.patch b/0000-start.sh.patch
new file mode 100644
index 000000000000..8eb829986752
--- /dev/null
+++ b/0000-start.sh.patch
@@ -0,0 +1,21 @@
+--- start.sh 2018-02-09 07:53:54.000000000 -0800
++++ start-n.sh 2022-03-03 01:49:55.856471116 -0800
+@@ -14,14 +14,13 @@
+
+ # Actions
+ run_game() {
+- echo "Running ${GAME_NAME}"
+- cd game
+- chmod +x "runner"
+- ./"runner"
++ echo "Running ${GAME_NAME}"
++ cd game
++ ./"runner"
+ }
+
+ default() {
+- run_game
++ run_game
+ }
+
+ # Options
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd514cda3263
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# Maintainer: dplusdplus <echo cmFuZG9tdGVzdG5hbWUtYXQtZ21haWwoZG90KWNvbQo= | base64 -d>
+
+_pkgname=va-11-hall-a
+pkgname=${_pkgname}-gog
+pkgver=1.2.3.0
+pkgrel=1
+arch=('i686' 'x86_64')
+license=(custom)
+groups=('games' 'gog')
+
+pkgdesc="Bartender simulator visual novel game"
+url="https://waifubartending.com"
+
+depends=(
+ 'lib32-glu'
+ 'lib32-libxrandr'
+ 'lib32-openal'
+ 'lib32-openssl-1.0'
+)
+makedepends=(
+ 'p7zip'
+)
+optdepends=(
+ 'firejail: sandboxing'
+)
+
+source=(
+ "gog://va_11_hall_a_cyberpunk_bartender_action_en_1_2_3_0_18496.sh"
+ "${pkgname}"
+ "${pkgname}.desktop"
+ "${pkgname}.profile"
+ "0000-start.sh.patch"
+)
+sha512sums=(
+ '1f5a10cc3b543b355adff3c09ae5e44f5050b20d3bfb9e704cfe06f2e894045d743ccf3e94aef5f7dd4b444e9cf18abc7800718f04280c83c441e46d664902da'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
+options=('!strip')
+
+# You need to download the gog.com installer file manually or with lgogdownloader.
+DLAGENTS+=("gog::/usr/bin/echo %u - This is is not a real URL, you need to download the GOG file manually to \"$PWD\" or setup a gog:// DLAGENT. Read this PKGBUILD for more information.")
+
+package() {
+ install -d "${pkgdir}/opt/${pkgname}"
+
+ cp -r "data/noarch/game/" "${pkgdir}/opt/${pkgname}/"
+ install -D -m 755 "data/noarch/start.sh" "${pkgdir}/opt/${pkgname}/"
+ install -D -m 444 "data/noarch/gameinfo" "${pkgdir}/opt/${pkgname}/"
+ install -D -m 755 data/noarch/support/*.{sh,shlib} --target-directory="${pkgdir}/opt/${pkgname}/support/"
+ install -D -m 644 "data/noarch/support/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+
+ # Executable permissions
+ chmod +x "${pkgdir}/opt/${pkgname}/game/runner"
+
+ install -d "${pkgdir}/usr/bin"
+ install -D -m644 "${pkgname}" "${pkgdir}/usr/bin"
+ chmod 555 "${pkgdir}/usr/bin/${pkgname}"
+
+
+ patch "${pkgdir}/opt/${pkgname}/start.sh" "0000-start.sh.patch"
+ chmod 755 "${pkgdir}/opt/${pkgname}/start.sh"
+
+
+ install -D -m644 ${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ install -D -m644 "data/noarch/docs/End User License Agreement.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Install firejail profile
+ install -D -m644 "${pkgname}.profile" "${pkgdir}/etc/firejail/${pkgname}.profile"
+
+}
diff --git a/va-11-hall-a-gog b/va-11-hall-a-gog
new file mode 100644
index 000000000000..649d5c4a7b0a
--- /dev/null
+++ b/va-11-hall-a-gog
@@ -0,0 +1,26 @@
+#!/bin/sh
+
+pkgname="va-11-hall-a-gog"
+pkgdir="/opt/${pkgname}"
+run="${pkgdir}/start.sh"
+run_firejail="firejail --profile=/etc/firejail/${pkgname}.profile ${run}"
+
+
+if hash firejail; then
+ echo "Firejail detected; attempting to enforce a sandbox..."
+ if [[ -f "${XDG_CONFIG_HOME}/firejail/${pkgname}.profile" ]]; then
+ echo "Firejail profile for ${pkgname} found in ${XDG_CONFIG_HOME}/firejail/"
+ echo "Enforcing a sandbox!"
+ eval "${run_firejail}"
+ elif [[ -f "/etc/firejail/${pkgname}.profile" ]]; then
+ echo "Firejail profile for ${pkgname} found in /etc/firejail/"
+ echo "Enforcing a sandbox!"
+ eval "${run_firejail}"
+ else
+ echo "No Firejail profile detected!"
+ echo "Skipping Firejail sandbox..."
+ eval "${run}"
+ fi
+else
+ ${run}
+fi
diff --git a/va-11-hall-a-gog.desktop b/va-11-hall-a-gog.desktop
new file mode 100644
index 000000000000..43c692ad3a53
--- /dev/null
+++ b/va-11-hall-a-gog.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=VA-11 Hall-A
+Comment=Bartender simulator visual novel game
+Exec=va-11-hall-a-gog
+Icon=va-11-hall-a-gog
+Type=Application
+Categories=Games
diff --git a/va-11-hall-a-gog.profile b/va-11-hall-a-gog.profile
new file mode 100644
index 000000000000..c11995427601
--- /dev/null
+++ b/va-11-hall-a-gog.profile
@@ -0,0 +1,42 @@
+include va-11-hall-a-gog.local
+include globals.local
+
+# VA-11 Hall-A configuration folders
+noblacklist ${HOME}/.config/VA_11_Hall_A
+mkdir ${HOME}/.config/VA_11_Hall_A
+whitelist ${HOME}/.config/VA_11_Hall_A
+
+include disable-common.inc
+include disable-devel.inc
+include disable-exec.inc
+include disable-interpreters.inc
+include disable-programs.inc
+include disable-write-mnt.inc
+include disable-xdg.inc
+
+# Disable network access
+net none
+
+apparmor
+caps.drop all
+nodvd
+nogroups
+noinput
+nonewprivs
+noroot
+notv
+nou2f
+novideo
+seccomp
+shell none
+tracelog
+
+disable-mnt
+private-cache
+private-dev
+private-etc machine-id
+private-opt va-11-hall-a-gog
+private-tmp
+
+dbus-user none
+dbus-system none