summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryzx92023-02-07 22:33:42 +0800
committeryzx92023-02-07 22:33:42 +0800
commitcb16ac2fe7b0c3086b233feaaf153302f57a1d0f (patch)
tree6f1c24761733b7fa7e4631ce8c94d2c85957f41d
parenteff7775d2a7f869298c691deebbe9cc79b0cdbd1 (diff)
downloadaur-cb16ac2fe7b0c3086b233feaaf153302f57a1d0f.tar.gz
upgrade to v3.601
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD28
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7cadf5557221..df9a4500c3c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = vaa3d-bin
pkgdesc = 3D Visualization-Assisted Analysis
- pkgver = v3.200
+ pkgver = v3.601
pkgrel = 1
url = https://www.vaa3d.org
arch = any
license = custom
depends = libpng12
+ depends = libtiff5
provides = vaa3d
conflicts = vaa3d
source = LICENSE::https://github.com/Vaa3D/Vaa3D_Wiki/wiki/LicenseAndAgreement.wiki
- source = vaa3d-v3.200.tar.gz::https://github.com/Vaa3D/release/releases/download/v3.200/Vaa3D_Ubuntu_64bit_v3.200.tar.gz
+ source = vaa3d-v3.601.tar.gz::https://github.com/Vaa3D/release/releases/download/v3.601/Vaa3D_CentOS_64bit_v3.601.tar.gz
sha256sums = SKIP
- sha256sums = fa267a6b02b340f9ab01f671dbd681bd5da1814abf31596170344106c07c19d8
+ sha256sums = d6f102c502a7be367ea7854bf561e492997ce0c19b4a0ad926fe1b308eead4f0
pkgname = vaa3d-bin
diff --git a/PKGBUILD b/PKGBUILD
index 9f3149be1f64..f63ae139e402 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,28 @@
pkgname=vaa3d-bin
_pkgname=${pkgname%-bin}
-pkgver=v3.200
+pkgver=v3.601
pkgrel=1
pkgdesc="3D Visualization-Assisted Analysis"
-arch=('any')
-url='https://www.vaa3d.org'
-license=('custom')
-depends=('libpng12')
+arch=("any")
+url="https://www.vaa3d.org"
+license=("custom")
+depends=("libpng12" "libtiff5")
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=('LICENSE::https://github.com/Vaa3D/Vaa3D_Wiki/wiki/LicenseAndAgreement.wiki'
- "${_pkgname}-${pkgver}.tar.gz::https://github.com/Vaa3D/release/releases/download/${pkgver}/Vaa3D_Ubuntu_64bit_${pkgver}.tar.gz")
-
-sha256sums=('SKIP'
- 'fa267a6b02b340f9ab01f671dbd681bd5da1814abf31596170344106c07c19d8')
+source=("LICENSE::https://github.com/Vaa3D/Vaa3D_Wiki/wiki/LicenseAndAgreement.wiki"
+ "${_pkgname}-${pkgver}.tar.gz::https://github.com/Vaa3D/release/releases/download/${pkgver}/Vaa3D_CentOS_64bit_${pkgver}.tar.gz")
+sha256sums=("SKIP"
+ "d6f102c502a7be367ea7854bf561e492997ce0c19b4a0ad926fe1b308eead4f0")
package() {
+ # license
+ install -Dm644 -t ${pkgdir}/usr/share/licenses/${pkgname}/ ${srcdir}/LICENSE
+
# binary
+ rm ${srcdir}/bin/libstdc++.so.6*
mkdir -p ${pkgdir}/opt/${pkgname}
- cp -r ${srcdir}/Vaa3D_Ubuntu_64bit_${pkgver}/* ${pkgdir}/opt/${pkgname}
+ cp -r ${srcdir}/bin/* ${pkgdir}/opt/${pkgname}
chmod 755 ${pkgdir}/opt/${pkgname}/${_pkgname}
cat>"${_pkgname}"<<EOF
@@ -29,7 +32,4 @@ export LD_LIBRARY_PATH=/opt/${pkgname}
/opt/${pkgname}/${_pkgname}
EOF
install -Dm755 -t ${pkgdir}/usr/bin ${_pkgname}
-
- # license
- install -Dm644 -t ${pkgdir}/usr/share/licenses/${pkgname}/ ${srcdir}/LICENSE
}