summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Steel2015-06-08 18:30:26 +0100
committerJonathan Steel2015-06-08 18:30:26 +0100
commitf1575c828df817512ecbf8a657b165d529e50b42 (patch)
tree6668abb86530ca1ff3ac0890f92cd8de9dd2fb76
downloadaur-f1575c828df817512ecbf8a657b165d529e50b42.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD50
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..929a99f495c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = vagrant-git
+ pkgdesc = Build and distribute virtualized development environments
+ pkgver = 1.7.0.5.g2385305
+ pkgrel = 1
+ url = http://vagrantup.com
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = ruby
+ depends = curl
+ depends = lzo
+ depends = libidn
+ depends = rtmpdump
+ conflicts = vagrant
+ options = !emptydirs
+ source = git://github.com/mitchellh/vagrant.git
+ source = git://github.com/mitchellh/vagrant-installers.git
+ source = http://pkgbuild.com/~jsteel/arch/vagrant/substrate_archlinux_.zip
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = vagrant-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9990d308b610
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Jonathan Steel <jsteel at archlinux.org>
+
+_pkgname=vagrant
+pkgname=vagrant-git
+pkgver=1.7.0.5.g2385305
+_pkgver=1.7.0
+pkgrel=1
+pkgdesc="Build and distribute virtualized development environments"
+arch=('i686' 'x86_64')
+url="http://vagrantup.com"
+license=('MIT')
+conflicts=('vagrant')
+options=('!emptydirs')
+makedepends=('git')
+depends=('ruby' 'curl' 'lzo' 'libidn' 'rtmpdump')
+source=(git://github.com/mitchellh/$_pkgname.git
+ git://github.com/mitchellh/$_pkgname-installers.git
+ http://pkgbuild.com/~jsteel/arch/$_pkgname/substrate_archlinux_$CARCH.zip)
+md5sums=('SKIP' 'SKIP')
+[[ $CARCH == i686 ]] && md5sums+=('c04042b24de56d18a041bc005e5ecaa4')
+[[ $CARCH == x86_64 ]] && md5sums+=('53d8a137e0b50fee8509a7d1c15fd33b')
+
+pkgver() {
+ cd $_pkgname
+
+ git describe --tags --long | sed 's/-/./g;s/^v//'
+}
+
+build() {
+ cd $_pkgname
+
+ REV=$( git log -n 1 --pretty=format:"%H" )
+
+ "$srcdir"/$_pkgname-installers/package/support/install_$_pkgname.sh \
+ "$srcdir"/substrate/ $REV "$srcdir"/substrate/${_pkgname}_version
+}
+
+package() {
+ install -d "$pkgdir"/{opt/,usr/bin/,usr/share/bash-completion/completions/}
+
+ cp -r "$srcdir"/substrate/ "$pkgdir"/opt/$_pkgname/
+
+ ln -s /opt/$_pkgname/bin/$_pkgname "$pkgdir"/usr/bin/$_pkgname
+
+ ln -s /opt/$_pkgname/embedded/gems/gems/$_pkgname-$_pkgver/contrib/bash/completion.sh \
+ "$pkgdir"/usr/share/bash-completion/completions/$_pkgname
+
+ install -Dm644 "$srcdir"/$_pkgname/LICENSE \
+ "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
+}