summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiao-Long Chen2015-06-08 22:04:55 -0400
committerXiao-Long Chen2015-06-08 22:04:55 -0400
commit2b26605cfe4f78c3e6294182ed371b81a7c9b0a9 (patch)
tree38f0cfa7db036d37e297a1230522eebcb224b6c9
downloadaur-2b26605cfe4f78c3e6294182ed371b81a7c9b0a9.tar.gz
Import from old AUR
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14d244e4692c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 4.2.0
+# Thu Jan 1 03:03:12 UTC 2015
+pkgbase = vala-git
+ pkgdesc = Compiler for the GObject type system
+ pkgver = 7085.9bcc61c
+ pkgrel = 1
+ url = http://live.gnome.org/Vala
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = libxslt
+ depends = glib2
+ provides = vala=0.26.1
+ conflicts = vala
+ conflicts = vala-devel
+ options = !libtool
+ source = git+git://git.gnome.org/vala
+ sha512sums = SKIP
+
+pkgname = vala-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59b9814ca473
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+# Original Maintainer: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Timm Preetz <timm@preetz.us>
+
+pkgname=vala-git
+pkgver=7085.9bcc61c
+pkgrel=1
+pkgdesc="Compiler for the GObject type system"
+arch=(i686 x86_64)
+url="http://live.gnome.org/Vala"
+license=(LGPL)
+depends=(glib2)
+makedepends=(git libxslt)
+provides=("vala=0.26.1")
+conflicts=(vala vala-devel)
+options=(!libtool)
+source=('git+git://git.gnome.org/vala')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd vala
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+prepare() {
+ cd vala
+
+ git describe --tag | sed 's/-.*//g' > .tarball-version
+}
+
+build() {
+ cd vala
+
+ ./autogen.sh --prefix=/usr --enable-vapigen
+ make
+}
+
+package() {
+ cd vala
+
+ make DESTDIR="${pkgdir}/" install
+}