summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-04-23 14:45:01 +0000
committerxiota2024-04-23 14:45:01 +0000
commit8cd7fbb41a70146362696215b5b152686100a4b3 (patch)
tree4938c064d40456d15a0f58e38f8e0170b85ecb17
parent1e85de679e1d66c7401ee4fc63017d9ee5dcb704 (diff)
downloadaur-8cd7fbb41a70146362696215b5b152686100a4b3.tar.gz
24.03
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD69
3 files changed, 50 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ee9c78f0c28..ed9d081b8e17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,18 @@
pkgbase = vala-panel
- pkgdesc = Gtk3 panel for compositing window managers
- pkgver = 0.5.0
+ pkgdesc = Panel for compositing window managers
+ pkgver = 24.03
pkgrel = 1
url = https://gitlab.com/vala-panel-project/vala-panel
arch = x86_64
- arch = pentium4
- arch = i686
- license = LGPL3
+ license = LGPL-3.0-only
makedepends = git
makedepends = meson
makedepends = vala
+ makedepends = gobject-introspection
+ depends = gtk-layer-shell
depends = gtk3
depends = libwnck3
- depends = gtk-layer-shell
- optdepends = vala-panel-appmenu-valapanel: Global Menu
- optdepends = vala-panel-sntray: SNI System tray
- optdepends = vala-panel-applets-xembed: Old system tray
- optdepends = vala-panel-applets-icontasks: Budgie tasklist
- optdepends = vala-panel-applets-genmon: GenMon applet
- source = vala-panel::git+https://gitlab.com/vala-panel-project/vala-panel.git#tag=0.5.0
+ source = vala-panel::git+https://gitlab.com/vala-panel-project/vala-panel.git#tag=24.03
sha256sums = SKIP
pkgname = vala-panel
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index a87f9d27c8ce..5784884a4f82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,50 @@
-# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
-# Contributor: rilian-la-te <ria.freelander@gmail.com>
-# Contributor: JoveYu <yushijun110@126.com>
+# Maintainer:
+# Contributor: Pellegrino Prevete <pellegrinoprevete@gmail.com>
-# shellcheck disable=SC2034
-pkgname="vala-panel"
-pkgver=0.5.0
+_pkgname="vala-panel"
+pkgname="$_pkgname"
+pkgver=24.03
pkgrel=1
-pkgdesc="Gtk3 panel for compositing window managers"
-url="https://gitlab.com/${pkgname}-project/${pkgname}"
-arch=('x86_64' 'pentium4' 'i686')
-license=('LGPL3')
-depends=('gtk3' 'libwnck3' 'gtk-layer-shell')
-makedepends=('git' 'meson' 'vala')
-optdepends=("${pkgname}-appmenu-valapanel: Global Menu"
- "${pkgname}-sntray: SNI System tray"
- "${pkgname}-applets-xembed: Old system tray"
- "${pkgname}-applets-icontasks: Budgie tasklist"
- "${pkgname}-applets-genmon: GenMon applet")
-source=("${pkgname}::git+${url}.git#tag=${pkgver}")
-sha256sums=('SKIP')
+pkgdesc="Panel for compositing window managers"
+url="https://gitlab.com/vala-panel-project/vala-panel"
+license=('LGPL-3.0-only')
+arch=('x86_64')
-prepare() {
- cd ${pkgname} || exit
- git cherry-pick -n 52f40ce779cfa224266dd427cfe57afd83a28362
-}
+depends=(
+ 'gtk-layer-shell'
+ 'gtk3'
+ 'libwnck3'
+
+ ## implicit
+ #at-spi2-core
+ #cairo
+ #dconf
+ #gdk-pixbuf2
+ #glib2
+ #hicolor-icon-theme
+ #pango
+)
+makedepends=(
+ 'git'
+ 'meson'
+ 'vala'
+ 'gobject-introspection'
+)
+
+_pkgsrc="$_pkgname"
+source=("$_pkgsrc"::"git+$url.git#tag=$pkgver")
+sha256sums=('SKIP')
-# shellcheck disable=SC2154
build() {
- meson build "${srcdir}/${pkgname}" --prefix=/usr --libdir=lib --libexecdir=lib -Dwnck=enabled -Dplatforms=x11,layer-shell
+ local _meson_options=(
+ -Dwnck=enabled
+ -Dplatforms=x11,wayland
+ )
+
+ arch-meson build "$_pkgsrc" "${_meson_options[@]}"
meson compile -C build
}
-# shellcheck disable=SC2154
package() {
- DESTDIR="${pkgdir}" meson install -C build
+ DESTDIR="$pkgdir" meson install -C build
}
-
-