summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin2024-03-19 22:28:13 +0300
committerKonstantin2024-03-19 22:28:13 +0300
commitcf227768fdbc52579e8eaf1ff74fe06457bdb369 (patch)
tree7e00e8b18205ca07ed183ff65259c1ee267757aa
parent4fcb2f3cb54c36f597cc437ee2b0ce2e887ee356 (diff)
downloadaur-cf227768fdbc52579e8eaf1ff74fe06457bdb369.tar.gz
new upstream version
-rw-r--r--.SRCINFO7
-rwxr-xr-xPKGBUILD8
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fdf0de9fc5ca..1f4d7b067eac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = vala-panel-git
pkgdesc = Gtk3 panel for compositing window managers
- pkgver = 0.5.2
+ pkgver = 24.03
pkgrel = 1
url = https://gitlab.com/vala-panel-project/vala-panel
arch = i686
arch = x86_64
- license = LGPL3
+ license = LGPL-3.0-or-later
makedepends = meson
makedepends = vala
makedepends = git
@@ -17,9 +17,10 @@ pkgbase = vala-panel-git
optdepends = vala-panel-applets-xembed: Old system tray
optdepends = vala-panel-applets-icontasks: Budgie tasklist
optdepends = vala-panel-genmon: GenMon applet
- provides = vala-panel=0.5.2
+ provides = vala-panel=24.03
conflicts = vala-panel-sntray
conflicts = vala-panel-sntray-git
+ conflicts = vala-panel
source = git+https://gitlab.com/vala-panel-project/vala-panel.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5f499ea49f52..39bda05f63d5 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
_pkgname=vala-panel
pkgname=${_pkgname}-git
-pkgver=0.5.2
+pkgver=24.03
pkgrel=1
pkgdesc="Gtk3 panel for compositing window managers"
url="https://gitlab.com/vala-panel-project/vala-panel"
arch=('i686' 'x86_64')
-license=('LGPL3')
+license=('LGPL-3.0-or-later')
depends=('gtk3' 'libwnck3' 'gtk-layer-shell' 'appmenu-glib-translator')
makedepends=('meson' 'vala' 'git')
provides=("vala-panel=${pkgver}")
-conflicts=('vala-panel-sntray' 'vala-panel-sntray-git')
+conflicts=('vala-panel-sntray' 'vala-panel-sntray-git' 'vala-panel')
optdepends=('vala-panel-appmenu-valapanel: Global Menu'
'vala-panel-applets-xembed: Old system tray'
'vala-panel-applets-icontasks: Budgie tasklist'
@@ -28,7 +28,7 @@ pkgver() {
}
build() {
- meson build "${srcdir}/${_pkgname}" --prefix=/usr --libdir=lib --libexecdir=lib -Dwnck=enabled -Dplatforms=x11,layer-shell
+ meson build "${srcdir}/${_pkgname}" --prefix=/usr --libdir=lib --libexecdir=lib -Dwnck=enabled -Dplatforms=x11,wayland
meson compile -C build
}