summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2018-03-25 21:49:38 +0200
committerMuflone2018-03-25 21:49:38 +0200
commit20e8b40fa26b820e5fb15464a6a7400f811f9abe (patch)
tree4fa57eb6d2028051279446e33da5a2af055caeca
parent266dbca490b8110e39509babfc61e8c8a12ce610 (diff)
downloadaur-20e8b40fa26b820e5fb15464a6a7400f811f9abe.tar.gz
Updated package vala0.12 0.12.1-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d71a4d5e86a..38e0ee736d8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Mar 25 19:48:29 UTC 2018
pkgbase = vala0.12
pkgdesc = Compiler for the GObject type system - version 0.12
pkgver = 0.12.1
- pkgrel = 1
+ pkgrel = 2
url = http://live.gnome.org/Vala
- arch = i686
arch = x86_64
license = LGPL
checkdepends = libx11
makedepends = gobject-introspection
makedepends = libxslt
+ makedepends = dbus
depends = glib2
options = !libtool
source = http://ftp.gnome.org/pub/gnome/sources/vala/0.12/vala-0.12.1.tar.xz
- sha512sums = 7f783aaf5b5a39f6d9d425a6c0ced10451454a7bc975c019dcbba83ea7c0cf381fc5647d3ac8dc5b3f94f611185ec7a30337c53ab68641513ba7c5bae31f7a0f
+ sha256sums = f102bb64549ebe88955bb9fa0f502d974413aec71fec88e3544c65adfeb0afb4
pkgname = vala0.12
diff --git a/PKGBUILD b/PKGBUILD
index 19b90a51ce02..22af28038a11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,46 @@
-# Maintainer: Muflone <webreg(at)vbsimple.net>
+# Maintainer: Muflone http://www.muflone.com/#contacts
# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Timm Preetz <timm@preetz.us>
pkgname=vala0.12
pkgver=0.12.1
-pkgrel=1
+pkgrel=2
pkgdesc="Compiler for the GObject type system - version 0.12"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://live.gnome.org/Vala"
license=('LGPL')
depends=('glib2')
-makedepends=('gobject-introspection' 'libxslt')
+makedepends=('gobject-introspection' 'libxslt' 'dbus')
checkdepends=('libx11')
options=('!libtool')
source=("http://ftp.gnome.org/pub/gnome/sources/vala/${pkgver%.*}/vala-${pkgver}.tar.xz")
-sha512sums=('7f783aaf5b5a39f6d9d425a6c0ced10451454a7bc975c019dcbba83ea7c0cf381fc5647d3ac8dc5b3f94f611185ec7a30337c53ab68641513ba7c5bae31f7a0f')
+sha256sums=('f102bb64549ebe88955bb9fa0f502d974413aec71fec88e3544c65adfeb0afb4')
build() {
- cd "${srcdir}/vala-${pkgver}"
+ cd "vala-${pkgver}"
./configure --prefix=/usr --enable-vapigen
make
}
check() {
- cd "${srcdir}/vala-${pkgver}"
+ cd "vala-${pkgver}"
make check
}
package() {
- cd "${srcdir}/vala-${pkgver}"
+ cd "vala-${pkgver}"
make DESTDIR="${pkgdir}" install
# Remove conflicting files with the vala package
rm -rv "${pkgdir}/usr/share/aclocal"
- for file in vala valac vala-gen-introspect vapicheck vapigen
+ for _file in vala valac vala-gen-introspect vapicheck vapigen
do
- rm -v "${pkgdir}/usr/bin/$file"
+ rm -v "${pkgdir}/usr/bin/${_file}"
done
- for file in valac.1 vala-gen-introspect.1 vapigen.1
+ for _file in valac.1 vala-gen-introspect.1 vapigen.1
do
- rm -v "${pkgdir}/usr/share/man/man1/$file"
+ rm -v "${pkgdir}/usr/share/man/man1/${_file}"
done
}