summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfusion8092016-10-18 02:39:47 +1000
committerfusion8092016-10-18 02:39:47 +1000
commitb4d47bb2e2ff156fd77bb670179726004ed0c164 (patch)
tree15a331cd56d51d46834a9a63bd936f9290070db9
downloadaur-b4d47bb2e2ff156fd77bb670179726004ed0c164.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99bf5b450d3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Oct 17 16:39:47 UTC 2016
+pkgbase = vala0.26
+ pkgdesc = Compiler for the GObject type system
+ pkgver = 0.26.2
+ pkgrel = 1
+ url = https://wiki.gnome.org/Projects/Vala
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = libxslt
+ makedepends = git
+ makedepends = vala
+ depends = glib2
+ provides = vala
+ source = git://git.gnome.org/vala#tag=0.26.2
+ sha256sums = SKIP
+
+pkgname = vala0.26
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ed92664ed9c4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.xz
+src
+pkg
+vala
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa5898ce52c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id$
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Timm Preetz <timm@preetz.us>
+
+pkgname=vala0.26
+_pkgname=vala
+pkgver=0.26.2
+pkgrel=1
+pkgdesc="Compiler for the GObject type system"
+url="https://wiki.gnome.org/Projects/Vala"
+arch=(i686 x86_64)
+license=(LGPL)
+depends=(glib2)
+provides=('vala')
+makedepends=(libxslt git vala)
+source=("git://git.gnome.org/vala#tag=$pkgver")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $_pkgname
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd $_pkgname
+ ./configure --prefix=/usr --enable-vapigen
+ make
+}
+
+package() {
+ cd $_pkgname
+ make DESTDIR="$pkgdir" install
+}