summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Gizdov2017-05-30 23:16:18 +0200
committerKonstantin Gizdov2017-05-30 23:16:18 +0200
commit221fb8c61eccda49c6a954a60aaa7f3afbc61511 (patch)
tree502ee327615d0d2303d68cff3cb1f69f81f6868f
parent5937633f228e139072d4e3abf0025eb093fb336a (diff)
downloadaur-221fb8c61eccda49c6a954a60aaa7f3afbc61511.tar.gz
updated to v0.7.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--enable_local_build.patch22
3 files changed, 25 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8e0adfef840..073b1ad23558 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vale
pkgdesc = A customizable, syntax-aware linter for prose.
- pkgver = 0.4.0
+ pkgver = 0.7.0
pkgrel = 1
url = https://github.com/ValeLint/vale
arch = i686
@@ -10,10 +10,10 @@ pkgbase = vale
makedepends = ruby
provides = vale
options = !emptydirs
- source = https://github.com/ValeLint/vale/archive/v0.4.0.zip
+ source = https://github.com/ValeLint/vale/archive/0.7.0.zip
source = enable_local_build.patch
- sha256sums = ebc36eda21835e1b46e09e0da9561f71870e5cfaf879bd99ffea466e15c5b48e
- sha256sums = 991b817b6e82ab53e18036386350af1e9e98f475cbf797d67f69ee94c2e33e8b
+ sha256sums = 82b731653f040c3b7a6c5ef01c596f13e10b43b2ecc689c8d4e010b252934ee6
+ sha256sums = 03be0c5d6b4e4c70346c8da348f5d8a51daffdc203f1f1d022a890da4d34e9f4
pkgname = vale
diff --git a/PKGBUILD b/PKGBUILD
index 1f310f8a0598..0b65a2c57830 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Konstantin Gizdov < arch at kge dot pw >
pkgname=vale
-pkgver=0.4.0
+pkgver=0.7.0
pkgrel=1
pkgdesc="A customizable, syntax-aware linter for prose."
provides=('vale')
@@ -10,10 +10,10 @@ license=('MIT')
depends=('')
makedepends=('go' 'ruby')
options=('!emptydirs')
-source=("https://github.com/ValeLint/${pkgname}/archive/v${pkgver}.zip"
+source=("https://github.com/ValeLint/${pkgname}/archive/${pkgver}.zip"
'enable_local_build.patch')
-sha256sums=('ebc36eda21835e1b46e09e0da9561f71870e5cfaf879bd99ffea466e15c5b48e'
- '991b817b6e82ab53e18036386350af1e9e98f475cbf797d67f69ee94c2e33e8b')
+sha256sums=('82b731653f040c3b7a6c5ef01c596f13e10b43b2ecc689c8d4e010b252934ee6'
+ '03be0c5d6b4e4c70346c8da348f5d8a51daffdc203f1f1d022a890da4d34e9f4')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -29,7 +29,8 @@ build() {
mkdir -p "${srcdir}/ruby"
export HOME="${srcdir}/ruby"
export GEM_HOME="${HOME}/.gem/ruby/${RUBY_VER}"
- export PATH="${srcdir}/gopath/bin:${GEM_HOME}/bin:$PATH"
+ export GEM_HOME_OLD="${HOME}/.gem/ruby/2.4.0"
+ export PATH="${srcdir}/gopath/bin:${GEM_HOME}/bin:${GEM_HOME_OLD}/bin:$PATH"
mkdir -p "${srcdir}/gopath/src/github.com/ValeLint/vale"
rsync -az "${srcdir}/${pkgname}-${pkgver}/" "${srcdir}/gopath/src/github.com/ValeLint/vale/"
cd "${srcdir}/gopath/src/github.com/ValeLint/vale"
diff --git a/enable_local_build.patch b/enable_local_build.patch
index 4f8c1c33daba..ae48ebcb53fa 100644
--- a/enable_local_build.patch
+++ b/enable_local_build.patch
@@ -1,14 +1,22 @@
-diff -aur vale-0.4.0-old/Makefile vale-0.4.0-new/Makefile
---- vale-0.4.0-old/Makefile 2017-04-02 20:07:57.000000000 +0200
-+++ vale-0.4.0-new/Makefile 2017-04-08 00:24:11.679719710 +0200
-@@ -76,7 +76,9 @@
+diff -aur vale-0.7.0-old/Makefile vale-0.7.0-new/Makefile
+--- vale-0.7.0-old/Makefile 2017-05-28 22:56:00.000000000 +0200
++++ vale-0.7.0-new/Makefile 2017-05-30 23:00:52.459912244 +0200
+@@ -5,6 +5,7 @@
+ CURR_SHA=$(shell git rev-parse --verify HEAD)
+
+ LDFLAGS=-ldflags "-s -w -X main.version=$(LAST_TAG)"
++RUBY_CUSTOM_PATH=/home/${USER}/.gem/ruby/$(shell ruby -e 'puts RUBY_VERSION')/bin
+
+ .PHONY: clean test lint ci cross install bump rules setup bench compare release
+
+@@ -66,7 +67,9 @@
+ go get -u github.com/alecthomas/gometalinter
go get -u github.com/jteeuwen/go-bindata/...
- go-bindata -ignore=\\.DS_Store -pkg="rule" -o rule/rule.go rule/
gometalinter --install
- bundle install
+ gem install bundle
-+ bundle install --path /home/gizdov/.gem/ruby/2.4.0/bin
++ bundle install --path ${RUBY_CUSTOM_PATH}
+ gem install specific_install
gem specific_install -l https://github.com/jdkato/aruba.git -b d-win-fix
- bump:
+ rules: