summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Gizdov2017-04-08 00:56:52 +0200
committerKonstantin Gizdov2017-04-08 00:56:52 +0200
commit5937633f228e139072d4e3abf0025eb093fb336a (patch)
tree43b4e8e5100fe9277c24675b3bc367f957f18862
downloadaur-5937633f228e139072d4e3abf0025eb093fb336a.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD53
-rw-r--r--enable_local_build.patch14
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8e0adfef840
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vale
+ pkgdesc = A customizable, syntax-aware linter for prose.
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/ValeLint/vale
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ makedepends = ruby
+ provides = vale
+ options = !emptydirs
+ source = https://github.com/ValeLint/vale/archive/v0.4.0.zip
+ source = enable_local_build.patch
+ sha256sums = ebc36eda21835e1b46e09e0da9561f71870e5cfaf879bd99ffea466e15c5b48e
+ sha256sums = 991b817b6e82ab53e18036386350af1e9e98f475cbf797d67f69ee94c2e33e8b
+
+pkgname = vale
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f310f8a0598
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Konstantin Gizdov < arch at kge dot pw >
+pkgname=vale
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="A customizable, syntax-aware linter for prose."
+provides=('vale')
+arch=('i686' 'x86_64')
+url="https://github.com/ValeLint/vale"
+license=('MIT')
+depends=('')
+makedepends=('go' 'ruby')
+options=('!emptydirs')
+source=("https://github.com/ValeLint/${pkgname}/archive/v${pkgver}.zip"
+ 'enable_local_build.patch')
+sha256sums=('ebc36eda21835e1b46e09e0da9561f71870e5cfaf879bd99ffea466e15c5b48e'
+ '991b817b6e82ab53e18036386350af1e9e98f475cbf797d67f69ee94c2e33e8b')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ msg2 'Patching...'
+ patch -p1 -i "${srcdir}/enable_local_build.patch"
+}
+
+build() {
+ cd "${srcdir}"
+ msg2 'Configuring...'
+ export GOPATH="${srcdir}/gopath"
+ export RUBY_VER=$(ruby -e 'puts RUBY_VERSION')
+ mkdir -p "${srcdir}/ruby"
+ export HOME="${srcdir}/ruby"
+ export GEM_HOME="${HOME}/.gem/ruby/${RUBY_VER}"
+ export PATH="${srcdir}/gopath/bin:${GEM_HOME}/bin:$PATH"
+ mkdir -p "${srcdir}/gopath/src/github.com/ValeLint/vale"
+ rsync -az "${srcdir}/${pkgname}-${pkgver}/" "${srcdir}/gopath/src/github.com/ValeLint/vale/"
+ cd "${srcdir}/gopath/src/github.com/ValeLint/vale"
+
+ go env
+ export BUNDLE_GEMFILE=$PWD/Gemfile
+ export PATH="${srcdir}/bin:${PATH}"
+ pip install --user docutils
+ gem install asciidoctor
+ make setup
+
+ msg2 'Compiling...'
+ make build
+}
+
+package() {
+ # cd "${srcdir}/build"
+ msg2 'Installing...'
+ install -Dm755 "${srcdir}/gopath/src/github.com/ValeLint/vale/bin/vale" "${pkgdir}/usr/bin/vale"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/vale/LICENSE"
+}
diff --git a/enable_local_build.patch b/enable_local_build.patch
new file mode 100644
index 000000000000..4f8c1c33daba
--- /dev/null
+++ b/enable_local_build.patch
@@ -0,0 +1,14 @@
+diff -aur vale-0.4.0-old/Makefile vale-0.4.0-new/Makefile
+--- vale-0.4.0-old/Makefile 2017-04-02 20:07:57.000000000 +0200
++++ vale-0.4.0-new/Makefile 2017-04-08 00:24:11.679719710 +0200
+@@ -76,7 +76,9 @@
+ go get -u github.com/jteeuwen/go-bindata/...
+ go-bindata -ignore=\\.DS_Store -pkg="rule" -o rule/rule.go rule/
+ gometalinter --install
+- bundle install
++ gem install bundle
++ bundle install --path /home/gizdov/.gem/ruby/2.4.0/bin
++ gem install specific_install
+ gem specific_install -l https://github.com/jdkato/aruba.git -b d-win-fix
+
+ bump: