summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Gizdov2018-03-03 15:38:04 +0100
committerKonstantin Gizdov2018-03-03 15:38:04 +0100
commitfc030a8b5bdf396e6b351d2587fbc837ece9a759 (patch)
tree4ecb88e7ddaaf9d277c2c05eb3f560daca87231b
parent080571ca1f80a4a18b42156da1e3ee6d77e29b10 (diff)
downloadaur-fc030a8b5bdf396e6b351d2587fbc837ece9a759.tar.gz
update to v0.10.1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
-rw-r--r--enable_local_build.patch18
3 files changed, 23 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8d3c632f8a6..0467d30532c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = vale
pkgdesc = A customizable, syntax-aware linter for prose.
- pkgver = 0.9.0
- pkgrel = 2
+ pkgver = 0.10.1
+ pkgrel = 1
url = https://github.com/ValeLint/vale
arch = i686
arch = x86_64
license = MIT
makedepends = go
makedepends = ruby
+ makedepends = python-docutils
provides = vale
options = !emptydirs
- source = https://github.com/ValeLint/vale/archive/0.9.0.zip
+ source = https://github.com/ValeLint/vale/archive/0.10.1.zip
source = enable_local_build.patch
- sha256sums = 9f561d157e0a4179c5f2ad880d74fd6f52b3f7aa22d93b57af5fa739aeac7d16
- sha256sums = 03be0c5d6b4e4c70346c8da348f5d8a51daffdc203f1f1d022a890da4d34e9f4
+ sha256sums = 8210ecea53c6715a3022dcb723f626f467072b8f7062fa9bb6d29a486278b6c8
+ sha256sums = 69f1efbd1f638cd601a0f5583b85a052aa5bbb6433a9d4a24dba11b29f703422
pkgname = vale
diff --git a/PKGBUILD b/PKGBUILD
index a253fd556d73..6e4d0ef820cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Konstantin Gizdov < arch at kge dot pw >
pkgname=vale
-pkgver=0.9.0
-pkgrel=2
+pkgver=0.10.1
+pkgrel=1
pkgdesc="A customizable, syntax-aware linter for prose."
provides=('vale')
arch=('i686' 'x86_64')
url="https://github.com/ValeLint/vale"
license=('MIT')
depends=('')
-makedepends=('go' 'ruby')
+makedepends=('go' 'ruby' 'python-docutils')
options=('!emptydirs')
source=("https://github.com/ValeLint/${pkgname}/archive/${pkgver}.zip"
'enable_local_build.patch')
-sha256sums=('9f561d157e0a4179c5f2ad880d74fd6f52b3f7aa22d93b57af5fa739aeac7d16'
- '03be0c5d6b4e4c70346c8da348f5d8a51daffdc203f1f1d022a890da4d34e9f4')
+sha256sums=('8210ecea53c6715a3022dcb723f626f467072b8f7062fa9bb6d29a486278b6c8'
+ '69f1efbd1f638cd601a0f5583b85a052aa5bbb6433a9d4a24dba11b29f703422')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -29,7 +29,7 @@ build() {
mkdir -p "${srcdir}/ruby"
export HOME="${srcdir}/ruby"
export GEM_HOME="${HOME}/.gem/ruby/${RUBY_VER}"
- export GEM_HOME_OLD="${HOME}/.gem/ruby/2.4.0"
+ export GEM_HOME_OLD="${HOME}/.gem/ruby/2.5.0"
export PATH="${srcdir}/gopath/bin:${GEM_HOME}/bin:${GEM_HOME_OLD}/bin:$PATH"
mkdir -p "${srcdir}/gopath/src/github.com/ValeLint/vale"
rsync -az "${srcdir}/${pkgname}-${pkgver}/" "${srcdir}/gopath/src/github.com/ValeLint/vale/"
@@ -38,8 +38,7 @@ build() {
go env
export BUNDLE_GEMFILE=$PWD/Gemfile
export PATH="${srcdir}/bin:${PATH}"
- pip install --user docutils
- gem install asciidoctor
+ gem install --no-rdoc --no-ri asciidoctor
make setup
msg2 'Compiling...'
diff --git a/enable_local_build.patch b/enable_local_build.patch
index ae48ebcb53fa..9a1751191516 100644
--- a/enable_local_build.patch
+++ b/enable_local_build.patch
@@ -1,22 +1,24 @@
-diff -aur vale-0.7.0-old/Makefile vale-0.7.0-new/Makefile
---- vale-0.7.0-old/Makefile 2017-05-28 22:56:00.000000000 +0200
-+++ vale-0.7.0-new/Makefile 2017-05-30 23:00:52.459912244 +0200
+diff -aur vale-0.10.1-old/Makefile vale-0.10.1-new/Makefile
+--- vale-0.10.1-old/Makefile 2018-02-17 04:00:48.000000000 +0100
++++ vale-0.10.1-new/Makefile 2018-03-02 00:01:30.630943963 +0100
@@ -5,6 +5,7 @@
CURR_SHA=$(shell git rev-parse --verify HEAD)
LDFLAGS=-ldflags "-s -w -X main.version=$(LAST_TAG)"
+RUBY_CUSTOM_PATH=/home/${USER}/.gem/ruby/$(shell ruby -e 'puts RUBY_VERSION')/bin
- .PHONY: clean test lint ci cross install bump rules setup bench compare release
+ .PHONY: data test lint ci cross install bump rules setup bench compare release
-@@ -66,7 +67,9 @@
+@@ -66,8 +67,10 @@
go get -u github.com/alecthomas/gometalinter
go get -u github.com/jteeuwen/go-bindata/...
gometalinter --install
- bundle install
-+ gem install bundle
+- gem specific_install -l https://github.com/jdkato/aruba.git -b d-win-fix
++ gem install --no-rdoc --no-ri bundle
+ bundle install --path ${RUBY_CUSTOM_PATH}
-+ gem install specific_install
- gem specific_install -l https://github.com/jdkato/aruba.git -b d-win-fix
++ gem install --no-rdoc --no-ri specific_install
++ gem specific_install -l https://github.com/jdkato/aruba.git
rules:
+ go-bindata -ignore=\\.DS_Store -pkg="rule" -o rule/rule.go rule/*.yml