summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCallum Parsey2022-11-24 22:31:00 +1030
committerCallum Parsey2022-11-24 22:31:00 +1030
commitb637b166db57d611f2bdd2a08eee7d1505da430b (patch)
tree523836b7b640269a311e1f69f269e2a3b8fd1af2
parent144bddf77223f9b0a77cd56187fe3832183c1fb0 (diff)
downloadaur-b637b166db57d611f2bdd2a08eee7d1505da430b.tar.gz
Add license info for bundled dependencies
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 22 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c81ae109964a..6accaac19dc2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,11 +4,18 @@ pkgbase = validatornu
pkgrel = 1
url = https://validator.github.io/validator/
arch = any
- license = custom
+ license = MIT
+ license = BSD
+ license = Apache
+ license = CDDL
+ license = EPL
+ license = MPL
depends = java-environment>=8
source = validatornu
source = https://registry.npmjs.org/vnu-jar/-/vnu-jar-22.9.29.tgz
+ source = https://raw.githubusercontent.com/validator/validator/22.9.29/CREDITS
sha256sums = 96cd47b569b8c79a60f3bea22159444919b418ef20d8beb4b223a6389aabbf25
sha256sums = 651b8183b1ffed596260b19b4e2865ff6f4711b1881fdbfe5525af4a72f7cd63
+ sha256sums = b7f78e603da0e9aa19adb63a3c12af5c8c16e40c43ac115a017cc7ed2517e9fb
pkgname = validatornu
diff --git a/PKGBUILD b/PKGBUILD
index 959d58e5dfe8..3671fa3c4d66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,16 +8,22 @@ pkgrel=1
pkgdesc="The Nu Html Checker, a command line tool for HTML5 markup validation"
arch=('any')
url="https://validator.github.io/validator/"
-license=('custom') # FIXME Should be expanded to MIT/dependency licenses
+license=('MIT' 'BSD' 'Apache' 'CDDL' 'EPL' 'MPL')
depends=('java-environment>=8')
-source=('validatornu'
- "https://registry.npmjs.org/vnu-jar/-/vnu-jar-$pkgver.tgz")
+source=("validatornu"
+ "https://registry.npmjs.org/vnu-jar/-/vnu-jar-$pkgver.tgz"
+ "https://raw.githubusercontent.com/validator/validator/$pkgver/CREDITS")
sha256sums=('96cd47b569b8c79a60f3bea22159444919b418ef20d8beb4b223a6389aabbf25'
- '651b8183b1ffed596260b19b4e2865ff6f4711b1881fdbfe5525af4a72f7cd63')
+ '651b8183b1ffed596260b19b4e2865ff6f4711b1881fdbfe5525af4a72f7cd63'
+ 'b7f78e603da0e9aa19adb63a3c12af5c8c16e40c43ac115a017cc7ed2517e9fb')
package() {
- install -Dm755 "$srcdir/$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 "$srcdir/package/build/dist/vnu.jar" "$pkgdir/usr/share/java/$pkgname/vnu.jar"
- install -Dm644 "$srcdir/package/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 "$srcdir/package/README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+ cd "$srcdir"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 CREDITS "$pkgdir/usr/share/licenses/$pkgname/CREDITS"
+
+ cd package
+ install -Dm644 build/dist/vnu.jar "$pkgdir/usr/share/java/$pkgname/vnu.jar"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
}