summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValérie Roux2022-12-26 12:04:23 +0100
committerValérie Roux2022-12-26 12:04:23 +0100
commit14ecd0d4ffa7ec13dcb27c6a34fb5d48a979e11b (patch)
tree3a2405c3d1333209333716288682519a6fb77fbe
parent49aa5820f4d69283f131fd5ede6b76041d8a0b55 (diff)
downloadaur-14ecd0d4ffa7ec13dcb27c6a34fb5d48a979e11b.tar.gz
Added python-pycryptodome and removed old pycrypto patch
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD12
3 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e6b91e7470b..8b70ce18d42f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,9 +6,9 @@ pkgbase = validity-sensors-tools-git
arch = x86_64
license = unknown
makedepends = python-setuptools
- depends = python-pycrypto
+ depends = python-pycryptodome
depends = python-pyusb
- depends = python-fastecdsa=1.7.4
+ depends = python-fastecdsa
depends = innoextract
depends = libusb
depends = usbutils
@@ -17,9 +17,6 @@ pkgbase = validity-sensors-tools-git
conflicts = validity-sensors-tools
conflicts = python-proto9x
source = validity-sensors-tools::git+https://github.com/3v1n0/python-validity.git
- source = 0001-Monkey-patch-time-to-fix-bug-in-pycrypto.patch
sha256sums = SKIP
- sha256sums = 9987b7765ff2921250de1c378b5cb8ac6f05d9f133211f0add358dffda6e33c1
pkgname = validity-sensors-tools-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4b06c270762c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+
+src
+pkg
+*.tar.xz
+*.tar.zst
+*.log
+.psci_modules
diff --git a/PKGBUILD b/PKGBUILD
index b2922947b5c6..242f0f08a39b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,9 +9,9 @@ arch=('x86_64')
url='https://github.com/3v1n0/python-validity'
license=('unknown')
depends=(
- 'python-pycrypto'
+ 'python-pycryptodome'
'python-pyusb'
- 'python-fastecdsa=1.7.4'
+ 'python-fastecdsa'
'innoextract'
'libusb'
'usbutils'
@@ -21,20 +21,14 @@ provides=("$_pkgname" "python-proto9x")
conflicts=("$_pkgname" "python-proto9x")
source=(
"$_pkgname::git+https://github.com/3v1n0/python-validity.git"
- "0001-Monkey-patch-time-to-fix-bug-in-pycrypto.patch"
)
-sha256sums=('SKIP'
- '9987b7765ff2921250de1c378b5cb8ac6f05d9f133211f0add358dffda6e33c1')
+sha256sums=('SKIP')
pkgver() {
cd "$_pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$_pkgname"
- patch -p1 < ../0001-Monkey-patch-time-to-fix-bug-in-pycrypto.patch
-}
build() {
cd "$_pkgname"