summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2024-06-10 18:13:48 -0500
committerHurricanePootis2024-06-10 18:13:48 -0500
commite2195366619f1995cb5d1c85e3a472876561470e (patch)
tree36a12c47aa931888e65c475cf05603930bc3c106
parentf7301c5a5cb00a98c9170767d34a76a2e6742e87 (diff)
downloadaur-e2195366619f1995cb5d1c85e3a472876561470e.tar.gz
use gendesk to create desktop file
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD25
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6921e541cd45..5223c45c8656 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = valveresourceformat-bin
pkgdesc = Valve's Source 2 resource file format parser, decompiler, and exporter.
pkgver = 10.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ValveResourceFormat/ValveResourceFormat
install = valveresourceformat-bin.install
arch = x86_64
license = MIT
license = CC-BY-2.5
+ makedepends = gendesk
depends = glibc
depends = gcc-libs
depends = zlib
diff --git a/PKGBUILD b/PKGBUILD
index 8a84e1adc104..db0836908f86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
pkgname=valveresourceformat-bin
pkgver=10.0
-pkgrel=1
+pkgrel=2
pkgdesc="Valve's Source 2 resource file format parser, decompiler, and exporter."
arch=('x86_64')
url="https://github.com/ValveResourceFormat/ValveResourceFormat"
license=('MIT' 'CC-BY-2.5')
depends=('glibc' 'gcc-libs' 'zlib' 'wine' 'bash' 'hicolor-icon-theme')
+makedepends=('gendesk')
conflicts=(valveresourceformat)
provides=(valveresourceformat)
options=(!strip !debug)
@@ -21,6 +22,15 @@ sha256sums=('d2128173623aa851427609a776568688431879cbf6607341bf604b2450bc70c6'
package() {
cd "$srcdir"
+ gendesk -f --pkgname=source2viewer \
+ --pkgdesc="$pkgdesc" \
+ --exec="${pkgname::-3}source2viewer" \
+ --name="Source 2 Viewer" \
+ --icon="${pkgname::-3}source2viewer" \
+ --terminal=false \
+ --categories="Development;Utility;Wine" \
+ --custom="PrefersNonDefaultGPU=true"
+
for file in {Decompiler,libSkiaSharp.so};
do
install -Dm755 $file "$pkgdir/usr/lib/$pkgname/$file"
@@ -44,18 +54,7 @@ EOF
chmod 755 "$pkgdir/usr/bin/${pkgname::-4}-source2viewer"
mkdir -p "$pkgdir/usr/share/applications"
- cat >> "$pkgdir/usr/share/applications/source2viewer.desktop" <<-EOF
-[Desktop Entry]
-Version=$pkgver
-Name=Source 2 Viewer
-Comment=Valve's Source 2 resource file format parser, decompiler, and exporter
-Exec=${pkgname::-4}-source2viewer %f
-Icon=${pkgname::-4}-source2viewer
-Terminal=false
-Type=Application
-Categories=Development;Utility;Wine;
-PrefersNonDefaultGPU=true
-EOF
install -Dm644 "$srcdir/ValveResourceFormat-$pkgver/Misc/Icons/source2viewer.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/${pkgname::-4}-source2viewer.png"
+ install -Dm644 "$srcdir/source2viewer.desktop" "$pkgdir/usr/share/applications/source2viewer.desktop"
}