summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2024-03-27 19:56:48 +0100
committerPhilip Goto2024-03-27 19:56:48 +0100
commit7cae4ea46235379fd37f9c383e3c2be1c309f158 (patch)
tree970f55c164be006a13ffdcb9b28a98dd205a16f5
downloadaur-7cae4ea46235379fd37f9c383e3c2be1c309f158.tar.gz
Initialize package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a31b1e7bf802
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vanilla-backgrounds-git
+ pkgdesc = Collection of light and dark backgrounds for Vanilla OS
+ pkgver = continuous.r0.g54ac40b
+ pkgrel = 1
+ url = https://github.com/Vanilla-OS/vanilla-backgrounds
+ arch = any
+ license = CCPL:by-sa-4.0
+ license = CCPL:by-4.0
+ makedepends = git
+ makedepends = glib2
+ makedepends = meson
+ depends = webp-pixbuf-loader
+ provides = vanilla-backgrounds
+ conflicts = vanilla-backgrounds
+ source = git+https://github.com/Vanilla-OS/vanilla-backgrounds.git
+ b2sums = SKIP
+
+pkgname = vanilla-backgrounds-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ecd7cec2259
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=vanilla-backgrounds-git
+pkgver=continuous.r0.g54ac40b
+pkgrel=1
+pkgdesc='Collection of light and dark backgrounds for Vanilla OS'
+arch=(any)
+url='https://github.com/Vanilla-OS/vanilla-backgrounds'
+license=('CCPL:by-sa-4.0' 'CCPL:by-4.0')
+depends=(webp-pixbuf-loader)
+makedepends=(
+ git
+ glib2
+ meson
+)
+provides=(vanilla-backgrounds)
+conflicts=(vanilla-backgrounds)
+source=("git+${url}.git")
+b2sums=('SKIP')
+
+pkgver() {
+ cd vanilla-backgrounds
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson vanilla-backgrounds build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ meson install -C build --destdir "${pkgdir}"
+}