summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAyush Jaipuriyar2022-08-25 01:31:30 +0530
committerAyush Jaipuriyar2022-08-25 01:31:30 +0530
commit6c9abb59c0ad14bed909cf29631116c64d04c2cf (patch)
tree01bd40b0fbcf0e2533c911d9467458e8390ba76f
downloadaur-6c9abb59c0ad14bed909cf29631116c64d04c2cf.tar.gz
First push
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f11b7768885a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vantage-14are05-git
+ pkgdesc = Battery manager to handle system performance modes and charge modes through acpi_calls (for ideapad 14are05 only).
+ pkgver = 26__2022.08.24
+ pkgrel = 1
+ url = https://github.com/ayushjaipuriyar/vantage-14are05
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = acpi_call
+ provides = vantage
+ source = git+https://github.com/ayushjaipuriyar/vantage-14are05
+ md5sums = SKIP
+ sha256sums = SKIP
+
+pkgname = vantage-14are05-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd5d6f4cf326
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Ayush Jaipuriyar <ayushjaipuriyar21@gmail.com>
+pkgname=vantage-14are05-git
+_gitname=vantage-14are05
+_name=vantage
+pkgver=26__2022.08.24
+pkgrel=1
+pkgdesc="Battery manager to handle system performance modes and charge modes
+ through acpi_calls (for ideapad 14are05 only)."
+url="https://github.com/ayushjaipuriyar/${_gitname}"
+arch=('x86_64')
+license=('GPL3')
+depends=('acpi_call')
+makedepends=('git')
+provides=('battmngr')
+provides=(${_name})
+source=("git+$url")
+sha256sums=('SKIP')
+md5sums=("SKIP")
+
+pkgver() {
+ cd ${_gitname}
+ _tag=$(git describe --tags | sed 's:^v::') # tag is mobile, and switches between numbers and letters, can't use it for versioning
+ _commits=$(git rev-list --count HEAD) # total commits is the most sane way of getting incremental pkgver
+ _date=$(git log -1 --date=short --pretty=format:%cd)
+ printf "%s_%s_%s\n" "${_commits}" "${_tag}" "${_date}" | sed 's/-/./g'
+}
+
+package() {
+ cd ${_gitname}
+ install -D vantage.sh "${pkgdir}/usr/bin/${_name}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_gitname}/LICENSE"
+}