summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-03-25 13:46:45 +0100
committersL1pKn072020-03-25 13:46:45 +0100
commit3cb36f9c0d364543553f4c116a20ee96f72b5b59 (patch)
tree50586203b40df7f7d6f18b4277b7380e99136600
parent20c7c2f548d6c28dc4ee99a22dc3b2c68b1fbd96 (diff)
downloadaur-3cb36f9c0d364543553f4c116a20ee96f72b5b59.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63beda1c30b0..54d55102435a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = vapoursynth-lib-vsfilterscript-git
pkgdesc = Library for Vapoursynth: vsfilterscript (GIT version)
- pkgver = r36.2dffdcd
+ pkgver = r37.98c5c11
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=181027
arch = x86_64
license = GPL
makedepends = git
- makedepends = gcc-git
- makedepends = gcc-libs-git
depends = vapoursynth
provides = vapoursynth-lib-vsfilterscript
conflicts = vapoursynth-lib-vsfilterscript
- source = vsfilterscript::git+https://github.com/IFeelBloated/vsFilterScript.git
+ source = vsfilterscript::git+https://github.com/IFeelBloated/vsFilterScript.git#branch=GCC9
sha256sums = SKIP
pkgname = vapoursynth-lib-vsfilterscript-git
diff --git a/PKGBUILD b/PKGBUILD
index 61acbbe9f325..0cd86a9ca5ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,17 @@
_plug=vsfilterscript
pkgname=vapoursynth-lib-${_plug}-git
-pkgver=r36.2dffdcd
+pkgver=r37.98c5c11
pkgrel=1
pkgdesc="Library for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://forum.doom9.org/showthread.php?t=181027'
license=('GPL')
depends=('vapoursynth')
-makedepends=('git'
- 'gcc-git'
- 'gcc-libs-git'
- )
+makedepends=('git')
provides=("vapoursynth-lib-${_plug}")
conflicts=("vapoursynth-lib-${_plug}")
-source=("${_plug}::git+https://github.com/IFeelBloated/vsFilterScript.git")
+source=("${_plug}::git+https://github.com/IFeelBloated/vsFilterScript.git#branch=GCC9")
sha256sums=('SKIP')
pkgver() {
@@ -28,7 +25,7 @@ prepare(){
cd "${_plug}"
echo "all:
- g++ -c -std=gnu++2a -fPIC ${CXXFLAGS//O2/O3} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o EntryPoint.o EntryPoint.cxx
+ g++ -c -std=gnu++2a -fconcepts -fPIC ${CXXFLAGS//O2/O3} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o EntryPoint.o EntryPoint.cxx
g++ -shared -fPIC ${LDFLAGS} -lstdc++ -o lib${_plug}.so EntryPoint.o" > Makefile
}
@@ -38,9 +35,9 @@ build() {
package() {
cd "${_plug}"
- install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+ install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/lib${_plug}.so"
- for i in *.h* *.cxx; do install -Dm644 "${pkgdir}/usr/include/vsfilterscript/${i}"; done
+ for i in *.h* *.cxx; do install -Dm644 "${i}" "${pkgdir}/usr/include/vsfilterscript/${i}"; done
install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}