summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-03-25 12:47:33 +0100
committersL1pKn072020-03-25 12:47:33 +0100
commit41257b127f8af8e86e08a9e2d5dd3bb50f84ceb2 (patch)
treee7d15f92476f9ed8401e42adbca3945992a47f94
downloadaur-41257b127f8af8e86e08a9e2d5dd3bb50f84ceb2.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD44
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63beda1c30b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vapoursynth-lib-vsfilterscript-git
+ pkgdesc = Library for Vapoursynth: vsfilterscript (GIT version)
+ pkgver = r36.2dffdcd
+ pkgrel = 1
+ url = https://forum.doom9.org/showthread.php?t=181027
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = gcc-git
+ makedepends = gcc-libs-git
+ depends = vapoursynth
+ provides = vapoursynth-lib-vsfilterscript
+ conflicts = vapoursynth-lib-vsfilterscript
+ source = vsfilterscript::git+https://github.com/IFeelBloated/vsFilterScript.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-lib-vsfilterscript-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93c152f326b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=vsfilterscript
+pkgname=vapoursynth-lib-${_plug}-git
+pkgver=r36.2dffdcd
+pkgrel=1
+pkgdesc="Library for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://forum.doom9.org/showthread.php?t=181027'
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git'
+ 'gcc-git'
+ 'gcc-libs-git'
+ )
+provides=("vapoursynth-lib-${_plug}")
+conflicts=("vapoursynth-lib-${_plug}")
+source=("${_plug}::git+https://github.com/IFeelBloated/vsFilterScript.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+# echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare(){
+ cd "${_plug}"
+
+ echo "all:
+ g++ -c -std=gnu++2a -fPIC ${CXXFLAGS//O2/O3} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o EntryPoint.o EntryPoint.cxx
+ g++ -shared -fPIC ${LDFLAGS} -lstdc++ -o lib${_plug}.so EntryPoint.o" > Makefile
+}
+
+build() {
+ LC_ALL=C make -C "${_plug}"
+}
+
+package() {
+ cd "${_plug}"
+ install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}