summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-04-25 17:27:30 +0200
committersL1pKn072017-04-25 17:27:30 +0200
commit713516ef47573001a934878b8eaf1de7b510a193 (patch)
treeecaeffa4b96fe0761d78e2875d30f1d5b0595d1b
downloadaur-713516ef47573001a934878b8eaf1de7b510a193.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fa8168942e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Apr 25 15:27:29 UTC 2017
+pkgbase = vapoursynth-plugin-autocrop-git
+ pkgdesc = Plugin for Vapoursynth: autocrop (GIT version)
+ pkgver = 0.1.3.g24626e1
+ pkgrel = 1
+ url = https://github.com/Infiziert90/vapoursynth-autocrop
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = vapoursynth
+ source = autocrop::git+https://github.com/Infiziert90/vapoursynth-autocrop.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-autocrop-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90d7bafd7446
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=autocrop
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=0.1.3.g24626e1
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url='https://github.com/Infiziert90/vapoursynth-autocrop'
+license=('GPL')
+depends=('vapoursynth')
+source=("${_plug}::git+https://github.com/Infiziert90/vapoursynth-autocrop.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+
+ echo "all:
+ g++ -c -std=c++98 -Wall -fPIC ${CFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o autocrop.o autocrop/autocrop.cpp
+ g++ -shared -fPIC ${LDFLAGS} -o libautocrop.so autocrop.o" > Makefile
+}
+
+build() {
+ make
+}
+
+package(){
+ install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+
+ install -Dm644 autocrop/README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}