summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-10-19 23:06:23 +0200
committerGustavo Alvarez2016-10-19 23:06:23 +0200
commita26cedf4d78dbf568f1faa20995d36641341d311 (patch)
tree5ea4214e3e4f48dc0373796b0de287d8a06a1ba2
parentba91d282aebe58245b081a893ee4d0ae0dc2c51a (diff)
downloadaur-a26cedf4d78dbf568f1faa20995d36641341d311.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9ed4804399a..1138a451dc0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Jan 18 00:29:18 UTC 2016
+# Wed Oct 19 21:06:13 UTC 2016
pkgbase = vapoursynth-plugin-averagehist
pkgdesc = Plugin for Vapoursynth: averagehist
pkgver = r0
@@ -7,9 +7,10 @@ pkgbase = vapoursynth-plugin-averagehist
url = http://forum.doom9.org/showthread.php?t=168521
arch = any
license = GPL
+ depends = vapoursynth
depends = vapoursynth-plugin-histogram-git
source = averagehist.py
- sha1sums = 7180cdb099965cd9cf300afad41e23fff4da82f6
+ sha256sums = 728334aa284a87c123c1d4a91b6ec826c07c46d56754532743d6e18cc60d01de
pkgname = vapoursynth-plugin-averagehist
diff --git a/PKGBUILD b/PKGBUILD
index 9662712a48a9..23bc295bd25a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,16 @@ pkgdesc="Plugin for Vapoursynth: ${_plug}"
arch=('any')
url='http://forum.doom9.org/showthread.php?t=168521'
license=('GPL')
-depends=('vapoursynth-plugin-histogram-git')
+depends=('vapoursynth'
+ 'vapoursynth-plugin-histogram-git'
+ )
source=('averagehist.py')
-sha1sums=('7180cdb099965cd9cf300afad41e23fff4da82f6')
+sha256sums=('728334aa284a87c123c1d4a91b6ec826c07c46d56754532743d6e18cc60d01de')
-_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
package(){
- install -Dm644 averagehist.py "${pkgdir}${_sites_packages}/averagehist.py"
+ install -Dm644 "${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
}