summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-10-04 17:53:45 +0200
committersl1pkn072015-10-04 17:53:45 +0200
commit0225a41731e057d878a74c47fd417c75f4b4edf1 (patch)
tree3d326da16c1490d7c9fc1e85d0f516cdce6d6556
downloadaur-0225a41731e057d878a74c47fd417c75f4b4edf1.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17e5f3f0bd8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vapoursynth-plugin-awarpsharp2-git
+ pkgdesc = Plugin for Vapoursynth: awarpsharp2 (GIT version)
+ pkgver = v6.0.g884986e
+ pkgrel = 1
+ url = https://github.com/dubhater/vapoursynth-awarpsharp2
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = yasm
+ depends = vapoursynth
+ provides = vapoursynth-plugin-awarpsharp2
+ conflicts = vapoursynth-plugin-awarpsharp2
+ source = awarpsharp2::git+https://github.com/dubhater/vapoursynth-awarpsharp2.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-awarpsharp2-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10c6c7085ff7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=awarpsharp2
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v6.0.g884986e
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url='https://github.com/dubhater/vapoursynth-awarpsharp2'
+license=('GPL2')
+depends=('vapoursynth')
+makedepends=('git' 'yasm')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd "${_plug}"
+ ./autogen.sh
+}
+
+build() {
+ cd "${_plug}"
+ ./configure --libdir=/usr/lib/vapoursynth
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.rst"
+}